0% Speed, 0 FPS, Frame: nan ms - Nothing works

Issue:
I had just started playing Pokémon Ultra Sun after completing X when a few minutes into the game my laptop died due to an empty battery. I plugged it in to charge and switched it back on to get back the five in-game minutes I had just lost but Citra did not work again after my laptop had died, reading the following: Speed: 0% / 100% | Game: 0 FPS | Frame: nan ms at the bottom.

This led me to multiple uninstallations and installations of Citra with no successful attempt whatsoever. I tried to find an answer online but nothing had helped. I downloaded the Canary version instead and updated my computer but it still didn’t work. I then reinstalled the game itself even though I imagine it won’t have anything to do with it and there was no progress either.

Furthermore: When I load the game despite what it reads, Citra freezes and doesn’t allow me to close unless I terminate the .exe through task manager.

Thanks in advance.

System Information

  • Operating System: Windows 10.
  • CPU: Core i7-9750H, 2.20GHz
  • GPU:
  • Citra Version: Citra Nightly 1552
  • Game: Pokémon Ultra Sun
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (14.2 KB)

System Information for Support

Client Version                                Nightly 1552 HEAD-7dc472a
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1070/PCIe/SSE2
GPU Driver Version                            416.83
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have GDB debugging enabled. This will cause Citra not to launch games. This is only intended for debugging purposes and should be disabled in settings.

How do I enable Accurate Multiplication? I would appreciate any pointers. As for GDB debugging, I recently enabled this in hopes it’d fix the issue as it was not working prior to enabling the option. It’s off now though!

Hi, do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

citra_log.txt (33.4 KB)

System Information for Support

Client Version                                Nightly 1399 HEAD-01686f7
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3337U CPU @ 1.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4358
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

For updating your drivers: Download win64_15.33.51.5146.zip (direct link) from https://downloadcenter.intel.com/download/29802/Intel-Graphics-Driver-for-Windows-15-33-?product=72055

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Additionally since you have a problematic GPU for citra, please disable New 3DS Mode in emulation>configuration>system to prevent random crashes/freezes from occuring. If that doesn’t work you’ll have to use an older version of citra until you upgrade your hardware: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392

After you’ve done all that, please follow these steps:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

citra_log.txt (9.5 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first before closing Citra then immediately upload a new log.

like this? citra_log.txt (18.1 KB)

System Information for Support

Client Version                                Nightly 1633 HEAD-bf03fb8
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i3-3110M CPU @ 2.40GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4358
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

Yup :slight_smile:

GPU Driver Version: 10.18.10.4358

This driver is outdated, you need to update.

Download win64_15.33.53.5161.zip from https://downloadcenter.intel.com/download/29969/Intel-Graphics-Driver-for-Windows-15-33-?product=65700
direct link: https://downloadmirror.intel.com/29969/a08/win64_15.33.53.5161.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Intel HD 4000 has driver bugs so you might need to use this older build until you buy a new computer: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392

citra_log.txt (25.4 KB)

System Information for Support

Client Version                                Canary 1887 HEAD-4df6a3f
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 3 2200G with Radeon Vega Graphics    
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) Vega 8 Graphics
GPU Driver Version                            20.11.1 27.20.12033.2007
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

Hi, please go to Emulation>Configuration>System and put the CPU Clock Speed back to 100%. Let us know if the problems continue.

I changed it from 100% to higher and lower, because I wanted to test if the problem kept reoccuring and it does.

Please upload another log file

I can’t upload the file cause it’s too big

Upload it to something like google drive or pastebin and link it here then.