A Link Between Worlds causes full system crashes

Issue:
I’ve been playing A Link Between Worlds almost flawlessly for roughly a week. Minor occasional hitches and slowdown, especially when entering new areas, and a singular, recurrent but very minor graphical glitch. Suddenly, yesterday, the game completely stopped functioning. It suddenly started taking an extremely long time to launch (almost 10 minutes on the Shaders screen), and then after I closed the game to go eat lunch, when I attempted to launch it again it got to a “Loading” screen, and then Citra’s RAM usage suddenly skyrocketed until it started using every single available byte of RAM on my system, causing a full PC crash. I tried again this morning and got the same result, but used Task Manager to close the emulator before it crashed my system again. I have already tried to reset my settings.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 2600
  • GPU: Nvidia GTX 1660
  • Citra Version: Nightly 1550
  • Game: The Legend of Zelda: A Link Between Worlds
  • Screenshot of Issue: Screenshot cannot be obtained as my system locks up faster than I can get an image.

Diagnostic Log
citra_log.txt (11.4 KB)

System Information for Support

Client Version                                Nightly 1550 HEAD-028609d
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2600 Six-Core Processor            
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

1 Like

This worked completely! Thank you so much. Getting a lot of microstuttering now, but I assume that’s because it’s having to re-prepare all the shaders, because they stop after I’ve spent a few minutes in an area.

Yeah the cache has to be rebuilt from scratch but it should work properly now.