A Link Between Worlds keeps crashing

Issue:
A Link Between Worlds opens a grey page with speed, frames and FPS (the loading page for games, I suppose), and then crashes out. No clue why.

System Information

  • Operating System: MacOS Big Sur
  • CPU: 5-nm 2.5 GHz Apple M1 8-core
  • GPU: Apple M1 GPU 7-core
  • Citra Version (found in title bar): Nightly 1714
  • Game: A Link Between Worlds
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (16.4 KB)

System Information for Support

Client Version                                Nightly 1714 HEAD-5241032
Operating System                              macOS 11.5
CPU                                           VirtualApple @ 2.50GHz
Graphics API                                  OpenGL 4.1
Graphics Renderer                             Apple M1
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

See this thread how to build for M1 as it’s not officially supported:

Before I try that, I would like to note that I have tried Project Mirai 2 and it’s worked just fine, it’s only happened when I tried to open A Link Between Worlds.

Alright, I’ve tried again and it seems to not have made a difference. I seem to be stuck for options here.

This was with your own M1 build? If yes then I’m afraid I don’t know.

Alright! I got it, finally. It seems that the solution was to turn off Hardware Shader. No clue why this works.