Ace Attorney Spirit of Justice gameplay-halting graphical problem

Issue:
When playing Phoenix Wright, Ace Attorney: Spirit of Justice, I come across an issue during the fingerprinting minigame where pressing one button input too many times in succession (how many is too many? I don’t know!) causes the game to freeze for a second, and then suddenly all graphics in the game are removed except for the barest bones of the interface.
You no longer know what you are dusting for prints, where you have already dusted, or where prints have already been found.
(pictured below is me dusting a coffin)
(Do you know what that button used to say? Because I forget.)

If you manage the first two sections through sheer guesswork, you get to a portion where you have to rotate a (now invisible) 3D object, find a smudge, dust it, and compare the fingerprint to a database.

You cannot save once this minigame begins, so my usual strategy of “reload and hope” is failing to apply.
I joined just to resolve this, because it seems like a unique problem.

A few times, attempting this minigame has caused my computer to freeze require a forced reboot, but dammit, I don’t care. If I can just beat it once, I can skip it from then onward.
Canary 1041 played through Dai Gyakuten Saiban and Dual Destinies just fine at over 100% speed. It’s just this one minigame.

System Information

  • Operating System: Lubuntu 18.10
  • CPU: Intel Core i7-7500U CPU @ 2.70GHz
  • GPU: Intel HD Graphics 620; NVIDIA GM108M GeForce 940MX
  • Citra Version (found in title bar): Canary-1041
  • Game: Phoenix Wright Ace Attorney: Spirit of Justice
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296citra_log.txt (43.4 KB)

System Information for Support

OpenGL Vendor                                 Intel Open Source Technology Center
OpenGL Renderer                               Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) 
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [x]
Enable Vsync                                  null
LLE Audio Emulation Enabled                   null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Tried every permutation of graphics settings.
All that one did was enable me to see the mushroomy dust cloud as I sprinkled it on stuff. Other stuff still went missing.
Thanks anyway, CitraBot.

(I know you’re automated; I’m using this response to inform other people.)

EDIT: No, I’m recalling incorrectly. I just tried it again, and it turned out “geometry shaders” shows dust clouds. Accurate multiplication just makes the graphics slightly more anti-aliased. The same glitch still happens in all cases.

I’d still like this resolved, but I’d like you to know that I downloaded a completed save file from some dude in Spain (some of the saves on his site are Spanish-language, and they’re all from PAL-region Nintendo games, so I’m guessing here. He might be from, IDK, Andorra or Gibraltar or something.).
(If anyone else has this problem, his name was marc robledo, and his name is his website)
As I said, once you complete the mini-game once, you can go to “Chapter Select” and never undergo this attempt at self harm again.

Again, this problem still exists, and I still have it, but since I can avoid this open manhole forever, it’s kind of low priority.