ACNL Boot issue related to Hardware Build in latest Nightly Build

Issue:
With the latest Nightly Build the game Animal Crossing New Leaf will boot to a black screen and not continue. The only method I found to troubleshoot this is to start the game without the Hardware Renderer enabled, letting the game run a little, and then turning the renderer back on. It runs perfectly like it used to with this workaround but the Hardware Renderer has to be re-disabled every time to boot the game.

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel® Core™ i3-6100T CPU @ 3.20GHz, 3192 Mhz
  • GPU: Intel HD Graphics 530
  • Citra Version (found in title bar): 1405 Nightly
  • Game: Animal Crossing - New Leaf welcome amiibo

Diagnostic Log
citra_log.txt (12.6 KB)

System Information for Support

Client Version                                Nightly 1405 HEAD-e428509
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [ ]
Enable Vsync                                  null
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Update: After looking through my settings and disabling the Disk Shader Cache (which seems like a new addition to Nightly Builds) I was able to boot up the game again like normal. Taking the Citrabot advice: Enabling Accurate Multiplication also worked (with Shader Cache on) but it ran noticeably slower than normal.