Add Shadowgift to MC In Fire Emblem: Awakening

I was debating whether or not to post about this, but I’m at my wits end right now.

This is a very specific problem, so I realize this may never be responded to, but if anyone has the time and know-how, I’d greatly appreciate it.

Basically, my end goal is to have the Main Character be able to use Dark Magic as a Tactician - a Dark Tactician, if you will. This is weirdly important to me, so I’ve tried a lot of methods to get it to work.

I first used the cheats on this page to try and give the MC Shadowgift, but it didn’t work.

Then I attempted to download both the Mac version of Cheat Engine and the Windows version (by using Wine). The Mac version won’t start up due to an error with the code signature, and the Windows version works - but can’t access Citra, as it’s on its own virtual machine of sorts.

I have the DLC as well as the main game, but I lost my cartridge a while ago (though I have a backup that I can restore from).

I’m tired of beating my head against the wall. Does anyone have any idea where to go from here?

Here’s my info:

MacOS X Mojave version 10.14.6
Processor: 1.3 GHz Intel Core i5
Memory: 4 GB 1600 MHz DDR3
(If this section is missing something, please let me know)

Citra Version: Citra Nightly 1358
Game: Fire Emblem: Awakening

Unfortunately, because I’m a new user, I can’t list all the screenshots I wanted to, so here’s some more info.

My MC’s currently a Dark Mage, but she noticeably doesn’t have Shadowgift, meaning that switching to Tactician would make her unable to cast dark magic.

(I also followed the directions on the cheat page and unequipped the skills on ALL of my characters - still didn’t work.)

The cheat I attempted to implement is 0134DE9C 00000057. Although it’s in accordance with the info on the cheat page above, it hasn’t worked.

citra_log.txt (40.1 KB)

Here’s my Citra log, and below is the error message I received when trying to open the Mac Version of Cheat Engine:

Blockquote
Process: Ascabart [7695]
Path: /Volumes/VOLUME/*/Installer.app/Contents/MacOS/Ascabart
Identifier: com.unrebuttableness.basiparaplastin
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Ascabart [7695]
User ID: 501

Date/Time: 2019-09-18 14:06:40.396 -0600
OS Version: Mac OS X 10.14.6 (18G95)
Report Version: 12
Anonymous UUID: 30350EDA-9620-5C45-522B-EF96F981AD89

Sleep/Wake UUID: 23C80722-6ADF-4FE4-9174-AB8FEBAEC02B

Time Awake Since Boot: 54000 seconds
Time Since Wake: 3300 seconds

System Integrity Protection: enabled

Notes: Translocated Process

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):
–>
__TEXT 000000010b997000-000000010b9ea000 [ 332K] r-x/rwx SM=COW

Thread 0 Crashed:
0 0x000000010f770000 _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007ffee4268ab0
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x000000010f770000 rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

Binary Images:
0x10b997000 - 0x10b9e9fff + (???) <361075F1-D756-3D8C-9378-F3069220346E>
0x10f76f000 - 0x10f7d970f + (655.1.1)

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 24143
thread_create: 0
thread_set_state: 22

VM Region Summary:
ReadOnly portion of Libraries: Total=948K resident=0K(0%) swapped_out_or_unallocated=948K(100%)
Writable regions: Total=8400K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8400K(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
STACK GUARD 56.0M 1
Stack 8192K 1
__DATA 236K 3
__LINKEDIT 188K 2
__TEXT 760K 2
shared memory 8K 2
=========== ======= =======
TOTAL 65.2M 11

I realize this is a Citra forum and not a Cheat Engine forum, but I figure that it can’t hurt.

Hopefully, this post is okay - I really, really want to find a way to resolve this. If you have any potential solutions, feel free to respond - thank you so much.

System Information for Support

Client Version                                Nightly 1358 HEAD-4b05078
OpenGL Vendor                                 Intel Inc.
OpenGL Renderer                               Intel HD Graphics 5000 OpenGL Engine
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

There are other programs similar to cheat engine out there, found one called bit slicer…

1 Like

Okay, I’ll give that a shot…

UPDATE:
Thank you so much! I feel foolish - I probably could have googled some Cheat Engine alternatives, but I guess I was in such a funk that I didn’t think of it. Thank you for breaking me out of it!

Bit Slicer seems to be working! After some research and fiddling, I found the address where the string “Shadowgift” is stored. Now I just need to figure out how to apply it to my character. It has the description “malloc” and not “text”, so I’m assuming it’s more than just the word “Shadowgift”…

So I’m in a little bit of a tricky place. If I dedicate enough time to the problem I currently have, I could probably solve it, but I’m going to post here again to potentially limit the amount of time I spend banging my head against a wall.

I’ve looked up a few tutorials regarding how to use Cheat Engine/Bit Slicer. I know some of the basics - looking up changing values to help determine what a variable refers to. However, most of the examples are with explicit number values - number of lives, amount of health, etc. I’m not finding anything that could help me easily identify the location of Shadowgift, let alone how to manipulate it.

My best guess is that what I’ll eventually need to do is find the variable identifying Shadowgift and plug it into an array that represents the Main Character’s abilities.

Am I on the right track? If anyone has that kind of knowledge, I’d love a response, or even just a few tips or tricks to help me work on this problem.

that can be very trick if you don’t have experience and patience on how to use find such values, you can try this tutorial bellow, i’m not sure if its going to work for your cheats.

1 Like

Sorry for the late response - I’ve seen that page before, and it didn’t seem to be what I needed, but I’ll experiment with it some more and see what happens.