Age of Calamity Final Mission Crash

I’m running the latest mainline build for Linux. The last mission constantly crashes after the part where you defeat corrupted Terrako (tried about 4 times and always crashes, docked or undocked). It just once happened to load after that cutscene and went up to the final boss defeated cutscene, following which the emulator crashed yet again. I don’t know what’s up with this.

CPU: AMD Ryzen 5 3550H
GPU: AMD Radeon RX 560X (Notebook Variant)
OS: Ubuntu 20.04.2 LTS
API: Vulkan
Log (file too big apparently, so here’s a drive link): https://drive.google.com/file/d/190V3G_a7sD7bHrLqxJnASyQ6ttis8dcP/view?usp=sharing

Any help is appreciated

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Apparently, it worked when I ran it on Windows. However, I was getting quite a performance hit (went from 25-30 fps to 18-20 fps).

You were running quite the old version of Mesa in the Ubuntu log, that could be one of the main reasons.

Oh. How do I update it?
Nvm found how to.