Age of Calamity: Severe FPS drops

Greetings,

I was emulating Hyrule Warriors: AoC on my Asus Tuf budget gaming laptop (Ryzen 7 and GTX1650) on both Windows 10 and Linux Mint 20 (because why not). It is not completely playable yet for me. The game crashes unless assembly shaders are not deactivated. I also fiddled with the Nvidia Control Panel as recommended by BSoD Gaming, while I installed the Nvidia driver and 5.8 kernel on Linux and set the image settings in OpenGL tab of Nvidia X Server Settings to maximum performance.

The game works fine at 27-30 FPS in menus, 25-28 FPS in open areas, 25 FPS most of the time, 20 FPS when there are many enemies around with FPS drops every here and there. Rendering is fine, but graphical glitches are quite common. Performance on Yuzu-486 does not vary much at all between the operating systems, although I would say the frame rate is more stable on Windows. Music works fine.

I cannot progress from Chapter 2: Attack of the Yiga clan. I did not manage to progress on Windows at all (Yuzu crashed). On Linux Yuzu does not crash, but the FPS rate is too low to do anything. It’s the same when I open the character roster - Windows crashes, Linux gives 0-2 FPS and I can only exit the roster by button mashing B.

Is there any way of alleviating this problem as of now? I also tried HW: AoC on my dad’s PC with Intel® Core™ i9-7980XE CPU, GTX 1050Ti GPU and 32 GB of RAM, but the performance was practically the same as on my laptop. I also tried to switch my graphics driver to Vulcan, but it didn’t help at all.

1 Like

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Not for now, but improvements are being worked on.

Awesome! I will just append my log file in case it might be useful.

My log file has about 5 MB, so it wouldn’t let me upload it here. I’ve saved my Windows yuzu_log.txt on google drive and it can be accessed here: https://drive.google.com/file/d/1JfSGuilYpRxxWGK2fMb0zNtZ4aCEqnjq/view?usp=sharing

See if updating the GPU driver helps you.

I updated Nvidia drivers on Windows and Linux and it had practically no effect.

New Windows log file (yuzu crashes): https://drive.google.com/file/d/1h-UqEmbuGHdV6FrgFIH_GNYZJokktMSz/view?usp=sharing

For comparison, I will also share the yuzu_log from Linux where Yuzu does not crash but the FPS doesn’t go above 5 FPS: https://drive.google.com/file/d/1-oyHrKP-1CDwFE-_oUQP0JxfFOWsoWtG/view?usp=sharing


Screenshot 1: The last cutscene I can see at full speed (unlike in other cutscenes Zelda doesn’t have that red glare in her eyes, which is good).

Screenshot 2: Windows crashes when loading this battle. I can only access it on Linux, but as you see it has 2 FPS or less, which is practically unplayable. Also during the cutscene in Hyrule town (before this battle), the lightning is all weird and the frame rate is also between 0 and 3 (if not skipped, that cutscene also crashes Yuzu on Windows).

I also have the same problem with this game. I even downloaded 60 fps mods and it still runs poorly. It looks smooth but everything is like in slow motion

Don’t use the 60fps mod as there is no real valid one. The emulator requires more optimization.

so what should i do instead. Because it was unplayable even with the 60 fps mod

Can stick to your console for now

bruh. So there isnt anyway i can fix the problem? Because from what i saw on youtube alot of people can play it smoothly on yuzu without any problems.

Could you post a log file? Getting Log Files - yuzu

Post a log like golden asked. Lots of videos are dated…

yeah okay of course.

yuzu_log.txt (294.4 KB)

Disable asynchronous shaders, it’s known to cause performance issues.
Set CPU accuracy to auto.
And revert back the Nvidia driver to a 472 one, like this: https://developer.nvidia.com/vulkan-beta-47285-windows-1110

Okay! Thanks alot m8

1 Like

idk if my pc is the problem but it didnt work that much…

i even lowered my settings

Post me an updated Vulkan log.