AMD GPU very low fps

Hey, could anyone please help me with yuzu? I have an issue with The Legend of Zelda: Links Awakening. Im using an AMD RX 580 and everytime I go inside a buidling/cave and go outside again my FPS are very low. Ive used an ingame overlay and discovered my GPU operates at only half of its max frequency now. This issue only appears in this one game. Is this a known issue? Thanks for any help!

What ive tried till now:

  • Roll back video drivers
  • Tried different EAs / the mainline build
  • Tried other games / searched for hardware related issues
  • 60 fps mod

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Switch Mods - yuzu try using the stable 60fps mod for zla

That one is already in use…

Please get me a log file: Getting Log Files - yuzu

yuzu_log.txt (850.7 KB)

Disable asynchronous shaders, set CPU accuracy to auto, use the latest Stable 60 FPS mod from here: Switch Mods · yuzu-emu/yuzu Wiki · GitHub
And don’t overdo it with the scaling, the 580 is not a powerful GPU, stick to 2x or 3x at most.

I actually forgot to mention an important detail: The game only lags with high GPU accuracy turned on which is needed to avoid the broken chain chomp. As I said my GPU does not boost its clocks when I play Link’s Awakening while every other game (even some even older ones) work perfectly fine

Follow this again. You posted another log with async on instead of off. @pLaYeR_01

I didn’t post anything. Now here’s the second log but the performance is still worse yuzu_log.txt (600.4 KB)

Still log with async on like before. Ensure to turn it off in per game config& global config

You turned off async gpu emulation by accident I believe (hence worse performance*)

So ive turned every A-Sync off and here’s the log. Ive already built a new shader cache so the stutters are not related to compiling shaders. As I said at first the performance is pretty good but the chain chomp is invisible now. I have to turn the GPU accuracy back to 'Normal’yuzu_log.txt (413.8 KB)
to make him reappear but as soon as I do that, the performance goes back down to about 30 FPS, even if I set it to ‘High’ again

Please make sure you keep async gpu emulation on. Asynchronous shaders was the only thing mentioned to turn off.

1 Like

Got that. Seems like it works now! Thank you very much for your help and your patience!

1 Like

No worries I am glad to hear it! :slight_smile: