AMD R9 200 still not working well

#1

Issue:
So I have two computers, one with Nvidia 1060 and the other is the AMD R9. So the big thread is gone but Citra still doesn’t run well with the AMD GPU. It seems to be solved but I could use help to see why. I’ll make a comparison using Fire Emblem Fates

AMD Hardware Shader Off

  • Town at 100%
  • 3D Cutscenes at 60%
  • 2D Portraits 100%

AMD Hardware Shader On

  • Town at 60%
  • 3D Cutscenes 17%, Graphic Errors (Should be in the uploaded image section if I uploaded it right)
  • 2D Portraits 100%

Nvidia Hardware Shader On
*Perfect, but this computer overheats so I’d like to use AMD if possible.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5 4690 3.5GHZ 4 CPU
  • GPU: AMD R9 200
  • Citra Version (found in title bar): Canary 567
  • Game: Fire Emblem Fates
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (28.9 KB)

#4

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#5

Interesting is that your cpu has more than double (single thread performance) than mine test pc cpu, and still, i get similar performance levels (15% slower on FEF) but with a pre-gcn AMD video card, AMD is pathological when it comes to OpenGL, performance may improve in the future (mostly on the citra side i would guess) but avoid AMD for now if you want performance.

you can also reduce internal resolution to improve performance.

1 Like
#6

Only a side note: M290X on MacOs still has some major slowdowns with recent Canary builds eg. in MARIO 3D Land 1-4 where I get 7fps with GPU rendering, while CPU offers 80% of original speed. (In earlier canary it was even faster with CPU i5 4690 almost 100%)

Of course I know Mac is a completely different story when it comes to OpenGL support, but still hoping for some support/improvement from Citra Dev team in case of GPU shaders. Also thank you for all the hard work!

1 Like
#7

its not pure cpu, its using the cpu only for emulating vertex shader and geometry shader (which are tasks that the 3ds gpu does). pure cpu is if you turn off the hardware renderer (and you’ll see that THAT is slower than dirt)

#8

Oh I see. I’ll correct it to Hardware Shader off then