Analog sticks stopped working?

I am using a Switch Pro Controller through bluetooth. Up until yesterday it was working just fine, then I update my GPU drivers and suddenly both the left and right analog stick axis dosent work on citra any longer. The click registers but not the axis. All of the other controller buttons work just fine. The analog sticks still work on every other game on my PC, just not citra. I have tried uninstalling and reinstalling the controller, with no success. Any help would be appreciated.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i7-4770K
  • GPU: Radeon RX 480
  • Citra Version : Canary 1845
  • Game: All

<citra_log.txt (4.0 KB) >

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Anyone available to help?

Verify that you get a response with them in Windows’ own controller thingy (joy.cpl).

Try the automap feature at the bottom in the Controls window in Citra configuration. If it doesn’t work, try bind the stick to random keyboard keys and then try to rebind them by using the “Set Analog Stick” button so you can see if you get a response (changes to Axis) or if they stays as keys.

I don’t have a Switch Pro Controller so I cannot test myself unfortunately.

Thanks for the response. The controller does register in windows and in fact works on every other game just not on citra. I dont see anything in controller configuration that says automap? I have tried the Set Analog Stick button and have even tried setting up the directions separately with no luck. Citra recognizes all buttons and even joystick clicks, but will not register stick movement at all

It should be here:

Interesting, that box does not exist for me. Just an empty space

Ah ok, yeah latest Canary is 1956. Auto Map didn’t exist in 1845.