Animal Crossing Happy Home Designer Graphical Glitches

Issue:

I’ve tested as many citra builds as I’m able and willing to without flooding my computer with files to try and find a build that works. The only builds I found were the ones from May 14th and prior. All other builds have various graphical glitches. From the loading “Lottie” to the speech bubbles, to most of the bottom screen, this game is just not able to function with all it’s graphics for me on any version of the nightly build. I’ve also looked at canary and tried to find a version that worked that also allowed me to load amiibo. All of the ones with amiibo support, and even the ones without-- that I can find-- have this graphical glitch. Except for the nightly build released on May 14th, 2018-- build 7861be6-- and any before that release. I have yet to find one that doesn’t have this glitch. I am aware it could be my computer, as my laptop is old and has old hardware. However, I’d still like to see if there’s a way to work around this, or a way to fix it, or if, because of my computer, I just won’t be able to play this one game. (If you didn’t know, the bottom of the screen is supposed to have a pattern, not have a completely blue background)

(This might sound grouchy, I’m just trying to be professional. Hope it comes across that way.)

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel® Core™ i3-4030U CPU @ 1.90GHz, 1900 Mhz, 2 Core(s), 4 Logical Processor(s)
  • GPU: Intel® HD Graphics Family
  • Citra Version (found in title bar): Citra Nightly 1504 (and any version after May 14th Nightly Version)
  • Game: Animal Crossing Happy Home Designer
  • Screenshot of Issue (include the full Citra window including titlebar):

    Diagnostic Log
    citra_log.txt (26.3 KB)

System Information for Support

Client Version                                Nightly 1504 HEAD-db5b8b9
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 4400
OpenGL Version                                3.3.0
GPU Driver Version                            20.19.15.4531
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1504 HEAD-db5b8b9
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 4400
OpenGL Version                                3.3.0
GPU Driver Version                            20.19.15.4531
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hm, that version is Nightly 689 and with 690 onwards this was added:


Your GPU probably doesn’t like it, however you have outdated drivers and you should update them.

Download win64_15.40.45.5126.zip from https://downloadcenter.intel.com/download/29474/Intel-Graphics-Driver-for-Windows-15-40-?product=81018
direct link: https://downloadmirror.intel.com/29474/a08/win64_15.40.45.5126.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Can I do that despite having a really old computer with really old parts?

Yes, I linked compatible drivers and a guide so you should have no issues.