Animal Crossing New Leaf crashes when loading

Issue:
New Leaf, which has worked without issue for several months, now crashes before even getting into the game.
If it helps, the loading time (just to get into the game) has grown steadily recently, going from almost instantly to having to wait like 5 mins+ to load.
Now it doesn’t even load at all.

System Information

  • Operating System: Windows 10
  • CPU: intel® core i7-7700K @ 4.20ghz
  • GPU: nvidia geforce gtx 1070
  • Citra Version (found in title bar): both canary 1855 and nightly 1627
  • Game: Animal Crossing - New Leaf
  • Screenshot of Issue (include the full Citra window including titlebar):
    no screenshot needed. It loads normally for a couple minutes then the window suddenly closes.

Diagnostic Log
log.txt (12.5 KB)

System Information for Support

Client Version                                Canary 1855 HEAD-79b5bcc
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1070/PCIe/SSE2
GPU Driver Version                            456.55
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

That’s something the Bot appears to tell everyone.
Is that a setting or something? I certainly haven’t touched any setting related to ‘multiplication’.
Hopefully a human being sees this…

You can enable Accurate Multiplication in Emulation > Configure... > Graphics > Advanced.

There is currently a bug with the Disk Shader Cache which requires the Accurate Multiplication to be enabled, else RAM usage would raise until Citra crashes.
To prevent this bug enable Accurate Multiplication, then go to File > Open Citra Folder and delete the shaders folder inside.

Following space’s instructions should solve your issue.

Hello, can you please look at my problem I’ve been waiting for over a day

Oh wow, seriously? The multiplication bug certainly seems like it’s the problem…

Before reading that, I deleted my Appdata/roaming/citra folder (after backing it up of course), and the problem disappeared - the game booted up instantly just like on the first day. I copied over my backed up save files and config file, and everything ran perfectly.

But after I played for maybe 30+ different sessions of citra (closing it and re-opening it), the load time steadily increased with every session, and it quickly became clear that it was slowly building up something over time, behind the scenes.
Inaccurate multiplication certainly seems a likely culprit for such an issue.

My biggest question is: Why in the world is this option off by default? Seems like a really dumb decision on someone’s part.

I’ve ticked the box, hopefully that fixes it.
It’ll need more testing, but to anyone who needs a quick solution:

Delete the user/appdata/roaming/citra folder, AFTER you back up your saves and config! Don’t delete those!

Thanks for everyone’s quick and helpful replies.
Except ‘musicvibes’, get out of here dude. Is it not possible to delete that person’s post? I want to.

Do this instead. The only part that’s being screwed up are the shaders. Deleting the entirety citra’s files every time is really unnecesary.

The bug also isn’t in Accurate Multiplication. It’s a bug in the Disk Shader Cache that occurs when Accurate Multiplication is turned off --> The disk shader cache will endlessly compile shaders, causing more and more ram usage until you crash. Deleting the opengl folder once + activating Accurate Multiplication is more than enough. As for why Accurate Multiplication isn’t on by default, I agree. Either Accurate Multiplication should be on by default or Disk Shader Cache shouldn’t be automatically enabled.