Animal Crossing New Leaf unable to save data

So I have been playing Animal Crossing New Leaf for a while now (i’d say for a few weeks with a bit of time traveling using the time offset from the emulator) and now today when I tried to save after a session it says “Unable to save. Your game will exit without saving.” and then it returned to the title screen. Also my savedata was gone, and on the title screen it also said “Unable to read save data. Hold (power button) to turn off the power, and then reinsert the Game Card.” I resetted the game and the savedata was still gone.

I do have 2 save-states from the same day (one of them is 2 minutes ahead from the other) with all the progress on it (and with the game running), but when I load one of them and save in-game it still gives the same error.

I’m not sure if it’s corrupted savedata since the game didn’t mention that it was corrupted, it just said that it wasn’t able to save and then it washed all of my progress at the title screen.

System Information

Diagnostic Log
citra_log.txt (462.7 KB)

Ok I fixed the problem, I went to the game’s files and deleted all the data files (the .dat files), and then I booted the game again and loaded my latest save, and the saving worked normaly again. Took me a while to figure out how to fix since I couldn’t find anything on the forums, but now everything is good