Animal Crossing New Leaf (Welcome Amiibo) Weather effects slowdown

Issue:
game slows down by about 50% when it is snowing

System Information

  • Operating System: Windows 10 Home - V1909
  • CPU: AMD Ryzen 7 2700
  • GPU: Radeon RX 480
  • Citra Version : Nightly 1399
  • Game: Animal Crossing New Leaf (Welcome Amiibo)
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (37.8 KB)

System Information for Support

Client Version                                Nightly 1399 HEAD-01686f7
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon (TM) RX 480 Graphics
OpenGL Version                                3.3.1
GPU Driver Version                            19.12.3 26.20.15003.5016
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Nightly 1399 HEAD-01686f7
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon (TM) RX 480 Graphics
OpenGL Version                                3.3.1
GPU Driver Version                            19.12.3 26.20.15003.5016
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Does it also slowdown at native 240p resolution? 10x that you are using is a bit overkill for 1080p :stuck_out_tongue: (with large layout you will see diminishing returns beyond 4x[the top screen is exactly 4x resolution on a 1080p monitor]).

Also slows down at native 240P

runs great without falling snowflakes effect even at 10X resolution

There seems to be some sort of problem on my end but maybe it’s an issue with the emulator?

edit… I also tried Enabling Accurate Multiplication it had no change on the slowdown

Hm, can you retest with Custom Textures disabled and remove Post processing filter?(FXAA) at 240p(try make the game boot at 240p).

Custom Textures disabled and removed Post processing filter(FXAA) at 240P

The settings were applied before launching the game and the slowdown still persists with snowflakes graphical effect

Diagnostic Log
citra_log.txt (37.6 KB)

System Information for Support

Client Version                                Nightly 1399 HEAD-01686f7
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon (TM) RX 480 Graphics
OpenGL Version                                3.3.1
GPU Driver Version                            19.12.3 26.20.15003.5016
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Thanks, a dev is interested to get a “microprofile” for the issue and it would be appreciated if you could screenshot one by following these steps.

  1. Keep using the same settings as before(240p, no post processing, no custom textures).
  2. Start the game and reach where it is slow.
  3. Open microprofile, View->Debugging->Microprofile
  4. Enable the following:

    Groups->[ALL]
    image
  5. Wait 3 minutes or so at the snowy screen then screenshot the MicroProfile window and upload it here.

Thanks for helping out! :slight_smile:

MicroProfile

Hope it helps I love this community :slightly_smiling_face:

Edit… Further investigation shows that it’s actually not the snow causing the Slowdown I believe it may actually be some sort of random event in the game that happened on the day that it snowed

Edit #2… I found what I believe is causing the slowdown


relevant wiki page

(I can reproduce it with a save file and a custom system time I backed up) and the slowdown sometimes gets worse as the character approaches the 3D snowflake

1 Like

Yeah that would be great :slight_smile: the dev responded that slow drawing is extremely ambiguous so it’s not helpful unfortunately, a save file would be great.

Just to double check, you performed the microprofile testing on Nightly build correct? I forgot to mention it in the steps but seeing your previous logs were done on Nightly I just assumed you continued to use it.

Yes the microprofile testing was done on the same Nightly build 1399

To reproduce the performance bug you have to copy my Citra system time settings (Jan-14-2020-T06:00:00) (6am)

and load my save

Edit… Looks like sharing save files is against the Citra community rules sorry :frowning:

Home Folder Files fall under warez / NAND files, do not ask for download links or post them!