Animal Crossing NL Frame ms is too high

Issue:
Enter a description of your issue here, in full detail.
Hello. So, I’m having a problem with animal crossing here. I get 55-60 fps stable all the time, but Frame ms is way too high. And it wasn’t like this before. It always was around 8-10ms, and went up to 16-17 at the beach. But now its always 16-17+ and sometimes jumps to 20ms+. What can i do about this? Will overclocking cpu over 100% in citra settings solve this? Thank you.
P.S: Citra Version in the screenshot is before I updated the emulator, but nothing changed.

System Information

  • Operating System: Windows 7
  • CPU: Intel Core i5 4590S
  • GPU: AMD Radeon R9 380
  • Citra Version (found in title bar): Citra Nightly 1584
  • Game: Animal Crossing New Leaf
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<citra_log.txt (4.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Your log is getting cut off but you should do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Hey. I did this, but it didn’t solve the problem :confused: Actually, i think now it’s even worse, lol. I got around 25-26ms at the market in the town. Check this log file. citra_log.txt (144.9 KB)

System Information for Support

Client Version                                Nightly 1584 HEAD-910cc9e
Operating System                              Windows 7 SP 1 (6.1)
CPU                                           Intel(R) Core(TM) i5-4590S CPU @ 3.00GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon (TM) R9 380 Series
GPU Driver Version                            19.12.3 26.20.15003.5016
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

Update the drivers to Adrenalin 2020 Edition 20.4.2: https://www.amd.com/en/support/graphics/amd-radeon-r9-series/amd-radeon-r9-300-series/amd-radeon-r9-380

Since you have AMD card, you probably can look into dual booting Linux to gain 2x-3x more performance in OpenGL.

I updated the drivers, but problem still remains. Also tried to turn off vsync, but it also did not help.

Ok, your other options are trying Linux or buy an Nvidia graphics card.

If was running fine tho. This all started only like 1-2 weeks ago, before that i never had this problem.

Also, if i try to boot it in linux, where are the game save files? Is it saving it in ROM itself? Or is it located somewhere else?

If you have the time, try bisect so we know what build made it worse for you:
https://github.com/citra-emu/citra-nightly/releases?after=nightly-1585

If you want to copy all saves from Windows you can open Citra then File->Open Citra Folder and copy sdmc folder. Paste it in ~/.local/share/citra-emu/ on Linux.

It started at 82-83 and still remains. I was able to reduce the lagging by increasing the resolution, which shouldn’t make any sense in the first place, but it works. Even though it still lags at the shopping district and by the beach. Hope you guys will find the source of the problem and fix it in the future builds.

Nightly 1581 is fine but not 1582, or?