Animal Crossing NL Welcome Amiibo Update Issue

I have tried running NL in the past and it didnt really work out. But trying it once again today, the game runs smoothly with steady 60FPS, which is really nice. The only thing being, that I would like to do is import my save game. I see that the dumped ROM file doesnt include the WA Update, thats also why Citra dumps a “garden.dat” save file instead of the newer “garden_plus.dat”. I can of course still edit the garden.dat with the save editor but I would like to import my save game from my cartridge, which is a newer garden_plus.dat file. It cannot be converted into an old garden.dat. Is there any way to dump the newer version (1.5) or get the update and put it an an extra folder or something?

Ill just drop this here, I belive you don’t need it though:
System Information

  • Operating System: Win 7
  • Citra Version: HEAD-72f9142
  • Game: ACNL Welcome Amiibo

it’s easier to dump and install the update via cia install, but updates may break some games.

That sounds like something to work with but how do I even dump an update? With JKSM?

Use GodMode9. Dumping updates is similar to the dumping installed title guide. Instead you search in 0004000e (this directory is for updates) and dump as standard CIA. Transfer the CIA to your PC and install with Citra (File -> Install CIA).

1 Like

Ayy it worked perfectly. I was about to pull a much more complicated solution thanks so much!
Also for the quick replies!

Mhh. When I put my savegame in there, It tells me that the save data is corrupted? Anyone any Ideas? The update is there, I can see it.

could start a new game, make a new save, then try to copy your 3ds save over again?
also upload your log.

1 Like

Tried that, not working. How do I get my log file? Since it is not Citra who crushes, the game tells me that my data is corrupted. This happens on the 3DS too sometimes if you mess something up. But I have no clue why it tells me this since it should be the exact same version.

your log:
when this corrupted save data screen appear, go to Emulation > Configure > Debug > Open Log Location. leave this folder open and close the emulator, and upload the citra_log.txt file.

I can’t be sure about this, but you may need to dump more of your 3DS’s firmware files, and put those in Citra. I have a nearly complete dump of my 3DS’s nand / firmware, and my copy of Animal Crossing New Leaf Welcome Amiibo loads my save file just fine.

1 Like

as @Kumoashi_Kaze said, you may need need extra files, and your log can point to what is missing.

1 Like

A lot of games on the 3DS don’t like it when a save file comes from another 3DS system and will either refuse to load it or will treat it like it’s bad or corrupted. The game will delete the bad save and start over. This can happen on Citra as well if you don’t have a complete copy of your user files. You also have to make sure that if a game has an Extra data file that you copy that too and not just the save itself.

uh huh, dumping save files already been a disaster the first try haha. Ive been playing NL for a long time and I copy saves from game to game to saveditor all the time… I tried copying the extra files, didnt work. Ill get the log this afternoon!!

Huuuh, the log files is there but empty? Maybe you guys open it with a different program? idk.
I cannot upload it, since it is empty…

each time you open citra a new log is generated, you can either locate the folder manually
or leave it open by going to Emulation > Configure > Debug > Open Log Location.
now, open citra, load the game, when you problem occur close citra, and look at your log, it should contain details about execution.

I understand what you’re trying to say but the log stays empty. I follow your instruction exactly - I delete any existing log file, leave the empty folder open. I open citra, a new (still empty) log file is made. I run ACNL, the above shown screen appears. I exit citra and open the log file - which is still empty…

on the debug tab, is the Global Log Filter set to *:Info ?

aight it was set to *:Ciritical !! So here you go, heres the log now.

citra_log.txt (18.8 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Anyone? tryna boost this thing here