Announcing Networking Support

I don’t believe anyone has identified the issue, so it’s hard to say.

After updating the canary build
The networking tab is missing

The multiplayer Qt integration conflicted, and we will be fixing this as soon as possible.

i see
thanks for your hard work

Will mystery gift in Pokemon games be supported?

@SonicEclipsed

1 Like

I say just edit the .main in a program like pkhex. I believe there’s program for doing what you want.

1 Like

Just wondering, any clues into how to get the local multiplayer working for games like mhx/mhxx? Curious to see how long till support for these will come out.

I don’t have much knowledge on what much changed between the wireless setup from MH4U and MHGen/X so not sure how difficult this would be.

MHX / MHXX have a networking bug which is present in many games (such as Pokemon X/Y, Animal Crossing, Triforce Heroes). It also has a bounty on top of it, so you know that fixing this bug is no easy task.

Final Fantasy explorers US also not working in the latest version… hoping to see it working in the future… great work otherwise

‘‘You are ussing a different version of Citra-Local-Wifi™ then the room you are trying to connect to’’ anyone can help me :'v?

Please update to the latest Citra Canary version. As there was an update that made old versions incompatible.

Hey there! Don’t mean to sounds like I’m begging for it or nothin’, just curious; Is there any chance the Dragon Quest Monsters games might get network support? More specifically, Joker 3 Professional. Seeing as they’re currently listed as incompatible. Is it feasible even?

Thanks!

Acoording to the newer multiplayer compatibility table, Joker 3 Professional works.

I’m having trouble using multiplayer, when I try to enter a room the message “you are using a different version of citra local wifi tm then the room your trying connect to” what should I do?

Update your Citra Canary build.

I have the same problem as Tulho_Malaquias, canary build is updated to HEAD-8343adb and checking for updates results in “no updates found” and yet literally every single room - I checked - throws the same error.

I am receiving the same error as Zactrife and others.

Me too.I’m having that very same error with the latest canary build for Windows 64bit.

Please wait. I think that there was a error in the latest Canary. @jroweboy should be able to give more details.

And it said “different” not “older”. You might try using a slightly older version.