Another SMT4 DLC topic

Issue:
Enter a description of your issue here, in full detail.

Hey all. I recently tried playing SMT4 on Citra Canary, and tried to dump my DLC for it (using the newest commit of gm9). Installing the CIA went smoothly, and a new pop-up at the start of the game even shows up saying that add-ons were being read from the ‘SD-card’. Unfortunately, when I tried to load my save file (where I was currently in a DLC quest) it kicked me out of the quest (screenshot below).

When I tried to apply for the DLC quest again, I couldn’t find any of them in the quest board, but all my demons that are DLC-specific are still available. Weird. Any support would be appreciated

System Information

  • Operating System: Windows 10
  • CPU: i7-6700HQ
  • GPU: GeForce GTX 960M
  • Citra Version (found in title bar): Canary #686
  • Game: Shin Megami Tensei IV (not apocalypse, USA version with accompanying update and DLC)
  • Screenshot of Issue (include the full Citra window including titlebar): https://puu.sh/B5hEZ/3a60a49aa1.png

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (46.5 KB)

I found some issues in that log that need resolving:

Does this occur in the latest Nightly build?

Yes, I removed all DLC files before reinstalling the newly dumped one: https://puu.sh/B7uNM/24554e1313.png
I also tried it on latest Canary (717), same result.

Log from nightly: https://puu.sh/B7uOK/c7a2cc1d2f.txt

I would say to dump your system files, but it seems like the only one the game is requesting is the bad word list, which I highly doubt is the issue.


This seems like a Citra DLC bug, your best bet is probably to keep track of the issue you made.