"Array Size too short" on load

Issue:
I was doing fine playing Pokemon Ultra Sun, but today when i try to load it, it gives me this error.
If only solution is downloading an old version then can you link me the version that works?
Thank you.

System Information

  • Operating System: Windows 10
  • CPU: Intel i7 6700HQ 3.5GHz
  • GPU: Nvidia Geforce GTX950m
  • Citra Version (found in title bar): 1502
  • Game: Pokémon Ultra Sun

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (45.3 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1502 HEAD-d5a962c
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 950M/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            442.74
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Save normally in game on the old version(i.e do not save state). Then on the new version load the save normally(do not load state). Now you can create new save states on the new version that loads the new correctly.

It looks like my i can’t reach the savestates i did. Do i have to restart now?

Ah wait, test Nightly 1502. There is a fix for this issue. You can read about it here:


Try it and let me know if it works :slight_smile: (just update normally as you have before).

I’m sorry i don’t understand this, is there a tutorial?

What I just linked is just information what it is about. So it’s just reading and nothing else :stuck_out_tongue:
Did you use our installer? Then you should just be able to start Citra and a pop up saying that there is an update.

Both Nightly and Canary doesn’t work and there seems to be no updates

What version(s) are you currently using? When you start Nightly/Canary what does it say at the top?

Both the latest(Nightly 1502 / Canary 1682) have this fix:


If it still doesn’t work let me know and I can try bring this up.

No it still doesn’t work and thank you for giving time for my problem, hope it goes well

It looks like my i can’t reach the savestates i did. Do i have to restart now?

Do you mean your save states are gone? Or still say “array size too short” ?

still says that. Crashes if i press continue and just stops the game if i say abort

1 Like

Thanks I will bring this up.

image

Tell us the exact version you are trying to load the state with.

Latest of Nightly and Canary
1502 and 1682

Thanks, can you check if any Nightly build between 1494-1501 loads or if 1493 is the last version?
You can test the older builds here: https://github.com/citra-emu/citra-nightly/releases

If you made a save state between Nightly 1494-1501 they are pretty much RIP and you need to load it in one of those versions and save in-game normally so you can load the normal save on the latest version to make new save states from.

Sorry for the inconvenience.

I can’t seem to find where i can reload my saves in 1494

Is the load state menu ‘empty’ ?

There is no load state under emulation

Ok, but there is on Nightly 1502 / Canary 1682? As you said it was still crashing when you tried.

yeah there were and they were the crashing ones

i reached my limit. I’m *** on Discord if you want to