Audio and controller input work, but no video

I opnened Citra the other day and it downloaded an update which left me with no video.

Booted up Zelda ALBW and as soon as it starts I can hear the game and the controller inputs, can go into file select and similar menus, but there is no video so I can’t see anything at all.

Any help is greatly appreciated.

  • Operating System: Windows 10 Home 64-bit (10.0, Build 18363)
  • CPU: Intel Core i7-8700 3.20 Ghz
  • GPU: NVIDIA GeForce GTX 1060 6GB
  • Citra Version (found in title bar): 1659
  • Game: Legend of Zelda a Link Between Worlds
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

You can just upload your log file in your post by pressing the upload button:


Or you can drag-and-drop it into text box.

Thanks for the reply.
Log seems to big to upload.

Ah, my bad. Should’ve seen that. In any case, let’s try updating your GPU drivers:
Download and install igfx_win10_100.9030.exe (direct link) from https://downloadcenter.intel.com/download/30066/Intel-Graphics-Windows-10-DCH-Drivers

If it doesn’t allow you to directly install this driver, you’ll have to manually downgrade to an older driver before you can upgrade to the latest:
Download win64_25.20.100.6373.zip (direct link) from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
Then follow this guide on how to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/
After following this guide, you should be able to install the latest driver without issue.

Lastly, make sure that when testing it out to not use any Save States. They are not the most reliable things and they tend to break across different Citra Versions. Use in-game saves instead.

Thanks you very much for all your help.

Seems like I got a different error…

I tried games on steam + other emulators, they all seem to be working perfectly.

That’s odd. Make sure you restart your pc and try it again before following the other steps below. Maybe the driver doesn’t update until a restart has occured. If that didn’t work, upload a log file so we can make sure that the drivers for your integrated graphics were installed correctly.

I just noticed that your opening post says that you also have an NVIDIA Geforce GTX 1060 6GB GPU. You should be using that one instead of the integrated graphics you’ve been using thus far (way better performance). You can force Citra to run on the GTX 1060 6GB by right clicking on your desktop and selecting NVIDIA Control Panel, then go to Manage 3D Settings and select Program Settings. Now select the Add button and look for citra-qt.exe. Now select the prefered graphics processor to the NVIDIA Geforce GTX 1060 6GB and launch Citra again.

Thank you for your time.

I followed all of your recommendations to the letter. unfortunately, none worked and I’m still getting the error from the screenshot above.

Here’s a new log, much shorter than the last one…

citra_log.txt (4.6 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first before closing Citra then immediately upload a new log.

The fact that SleepingSnake saw that you were running on your iGPU instead of GTX 1060 means that you will need to connect your monitor to the graphics card and not the motherboard. That is how it works on desktop computers (i7-8700 is a desktop CPU).

You should show the driver tab in Device Manager for the iGPU (Intel UHD Graphics 630) so we can double check that the drivers were installed properly.

1 Like

Thank you both so much for your time.

Apparently I’d done some cable mismanagement and ended up with exactly that, DP was on the motherboard rather than the GPU.

Thanks again!

1 Like