[Audio Issue] Fire Emblem Three Houses - Faint audio stutter since version 1034

Hello team,

Today I wanted to play a bit of FE3H so I updated Yuzu to the latest version (1034) and booted the game.

First thing I noticed was that the shader loading was a bit slower than usual but that was not the main concern here. Once I reached the main menu I started noticing some very brief and faint audio stutters during music playback. If I could compare them to anything, I would say they’re a bit similar to the old days when you would plug in a microphone in a jack (but not loud - just faint and brief). If I go to the extras menu and play different music tracks, it will persist there. If I load the game, the same behavior can be noticed in-game as well.

I already played 70+ hours of the game and this was not an issue on earlier versions, so I’m thinking something may have happened during your latest updates so wanted to bring this to your attention.

What I did:

  • Updated video drivers to latest
  • Deleted (but backed up) shader folder to generate new shaders
  • Rebooted PC, checked for updates, etc
  • Tested other games like Astral Chain, Xenoblade Chronicles, Aegis Rim - none of those seem to present similar behavior
    -Monitored FPS - seems stable (29-31) when these occur.

If this may be something caused on my side, I’m open to suggestions - although to be honest, not much changed in my configuration since :slight_smile:

In order for us to provide better support, we need to see the log generated by yuzu. This guide will walk you through how you can obtain the log file: Getting Log Files - yuzu

yuzu_log.txt.old.txt (1.1 MB)

Log was over 5MB so I had to cut from it.

System Information for Support

Client Version                               yuzu 1034
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i9-9900KF CPU @ 3.60GHz | AVX2 | FMA
Graphics API                                 Vulkan 1.3.212
Graphics Renderer                            AMD Radeon RX 6700 XT
GPU Driver Version                           AMD proprietary driver 2.0.226
CPU Accuracy                                 Auto
GPU Accuracy                                 High
Docked Mode                                  [x]
CPU Multicore                                [x]
Async GPU                                    [x]
Async Shaders                                [ ]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Hmm log looks clean.
Can you confirm if this happens with an older driver? 22.3.1 for example.

Hi GoldenX86,

Thanks for the fast reply! Just tested with 22.3.1 driver from March and the issue is still there.

Here is an audio clip (blank video) with an example:

Stutter intervals:

  1. Between second 2 and 3
  2. ~ second 8 marker
  3. Between second 13 and 14
  4. ~ second 19

Like I mentioned, they’re faint and brief but I’m assuming that anyone with a decent hearing can get distracted by it.

Please let me know what you think.

Thanks!

Hi GoldenX86,

I decided to do some extensive testing and thought that I’d share the results with you.

I did some additional testing with Yuzu 1010 and 1020. With latest AMD drivers Yuzu would crash on FE3H launch so I went back to 22.3.1 drivers.

To my surprise I was able to replicate the issue there as well. So I did extra troubleshooting on all versions (1010, 1020, 1037* - most testing performed on 1037 with 22.5.2 drivers) and here is what I found.

  1. Other Yuzu games (13 Sentinels, Astral chain music playback for 5 + mins) or (intensive) PC games do not exhibit similar behavior
  2. If I turn off my headset and turn it back on, the audio issue in Fire Emblem Three Houses is still there
  3. However if I unplug my USB receiver (Logitech G935 wireless) and plug it back again (or do the same with a wired headset), the issue becomes fixed and the stuttering goes away. I was ready to call this a fix, but as I was writing this message I left the music player from the extra menu running and SADLY - the stuttering came back after a few minutes of continuous playback of the same track.
  4. I’ve reinstalled Logitech GHUB, tested with another pair of wireless audio (Galaxy Buds) and also tested with a pair of wired headset via onboard Realtek audio. To my surprise all of them are exhibiting the stuttering.

Went back to various driver versions even with factory reset (22.3.1, 22.3.2, 22.4.2, 22.5.1) and removed all Windows updates from May as those were pretty much the only thing that happened since I took a break from the game a few weeks ago. That and the DS controller firmware update, but made sure to test with it unplugged as well. Tested with a fresh image to exclude corruption, and even an old Yuzu version (565).

So after over 5 hours of wasted time, I’ve concluded that my PC might be possessed and I need to find a master exorcist. Whatever happens only during FE3H gameplay and the fact that unplugging/re-plugging either wired or wireless headset will remove any audio issues for a few minutes leaves me completely baffled. This issue has definitely transcended video drivers, audio drivers, windows updates… and common sense (as everything else works just fine).

Apologies to have wasted your time, this does not seem to be a Yuzu related issue after all. Now I regret not finishing the game before this happened :frowning:

2 Likes

I would wait a bit before calling the priest, we’re working on audio improvements and there’s the chance that it covers corner cases like yours.

1 Like