Audio Issues - Several games - Crackly, buzzy audio

Issue:
I am trying to play Inazuma Eleven 3 on citra but as soon as the game starts, theres extreme audio issues, it’s very bad quality and is hard to listen to, I want to do a gameplay of it so the audio quality won’t do. This problem exists with Inazuma Eleven 3 Bomb Blast, Lightning Bolt and Team Ogre Attacks. Every other Inazuma game I’ve tested has run fine.

System Information

  • Operating System: Windows 10 Home
  • CPU: AMD X4 760K Quad Core Processor 3.80 Ghz
  • GPU: NVIDIA GeForce GTX 650
  • Citra Version (found in title bar): Citra Canary 1758
  • Game: Inazuma Eleven 3
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (104.1 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1758 HEAD-9b0a1d1
Operating System                              Windows 10 (10.0)
CPU                                           AMD Athlon(tm) X4 760K Quad Core Processor     
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 650/PCIe/SSE2
GPU Driver Version                            441.66
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I tried that already, it had no effect.

Are you able to maintain 100% speed? It will sound bad if you don’t.

The speed stays around 93-99 when the bad audio is present.

Try record a clip, I assume there is like static noise that hurts your ears but if it just slows down then that is normal. Your 10 year old Athlon isn’t exactly Ryzen :stuck_out_tongue:

It isn’t running at 100% but that’s only because I’m downloading something, I can assure you, the audio is the same when running at 100%
I show another game at the end to show that that one is running fine.

I’m having a similar issue with Fire Emblem Echoes, the start cut-scene has bad audio but then it seems fine at the start screen. Is this a compatibility issue maybe?

System Information for Support

Client Version                                Canary 1758 HEAD-9b0a1d1
Operating System                              Windows 10 (10.0)
CPU                                           AMD Athlon(tm) X4 760K Quad Core Processor     
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 650/PCIe/SSE2
GPU Driver Version                            441.66
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

This is now 4 games with series audio issues and I’ve no idea what the problem is, I’ve tried the accurate audio and even though it’s a lot slower frame rate, the audio is still buzzy.

Try enable Audio Stretching.

Hmm that fixed the audio issues in Fire Emblem: Echoes but the 3 Inazuma Eleven games remain the same.

Ok, perhaps that game has some issues with HLE audio atm. Sorry for the inconvenience.

Ah ok, do you know approximately how long that might take to fix?

Solved setting “lle” audio and not “hle”

This changed nothing except for slowing the emulation down, the audio remains the same quality.

hi @MFlynny86 i have the same problem that u have with both inazuma eleven 3 games ;(, did u fixed that problem?

No sorry, seems to be a compatibility issue, so we’ll probably have to wait for the citra team to fix it which may take some time.