Black screen, I need help

Issue:
Hi, I’m a new French user of Citra. I have a problem when I try to launch a game, I have the sound but I just have a black screen, I can’t play like this…

System Information

  • Operating System: Mac OS X
  • CPU: ?
  • GPU: ?
  • Citra Version (found in title bar): Citra Nightly 1444
  • Game: All games
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (22.1 KB)

System Information for Support

Client Version                                Nightly 1444 HEAD-25ebf03
OpenGL Vendor                                 Intel Inc.
OpenGL Renderer                               Intel(R) Iris(TM) Plus Graphics 640
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

There is a bug on macOS and iirc you need to resize the window or toggle fullscreen(you can access it under the View menu).

I put the fullscreen on and it didn’t works

Moreover I don’t know how I can enabling “accurate multiplication”.

It is not recommended to enable it on macOS from my understanding.
What version is your mac? Catalina 10.15 or?

Frontend citra_qt/main.cpp:GMainWindow:182: Host OS: macOS 10.15

Ah nvm, it said in the log :stuck_out_tongue: Sadly I don’t know much about macs, I do know that Catalina(macOS 10.15) causes a lot of issues - at least what’s been reported on forums.

Check the App Store, maybe there is an update and hopefully it fixes some of these issues. Apple has deprecated OpenGL so that might also be a factor :frowning:

Ok thank u very much, I will check for an update to my Mac…

and thank you for your reactivity :wink:

Ok now it works ! I’ve found the problem, I was in a “beta” update of Mac OS. I download a new update and it works perfectly !

You put me on the right way ! So thank you very much !

1 Like