Black screen in pokemon games

Issue:
Pokemon games do not work at all. The audio plays but there’s a black screen

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel(R) Core™ i5-7200 CPU @ 2.50GHz 2.70 GHz
  • GPU: Intel(R) HD Graphics 620
  • Citra Version (found in title bar): 1822
  • Game: Pokemon Alpha Sapphire (plus all other gen 6 & 7 games)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (2.2 MB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1822   HEAD-ae3d50f
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) HD Graphics 620
GPU Driver Version                           27.20.100.9171
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

^ This driver is out of date. To update, download and install gfx_win_101.3790_101.2114.exe from Intel® Graphics – Windows* DCH Drivers
Mirror download: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe

Let me know if you encounter any issues during the installation.

Additionally, you should re-enable Hardware Shaders in Emulation>Configuration>Graphics>Advanced Tab. Then try your game again. If the same issues remain, upload a new log file.