Black screen on Omega Ruby while trying to put HM Moves to pikachu (but the game still running with black screen instead of normal screen)

#1

Issue:
Enter a description of your issue here, in full detail.
Black screen on Omega Ruby while trying to put HM04 Strength to pikachu (but the game still running with black screen instead of normal screen) or sometimes it got freezed the screen but the game is still running too
and i’m afraid that there’s more freezing or black screen issues to come
System Information

  • Operating System: Windows 10
  • CPU: Processor Intel® Core™ i5-7200U CPU @ 2.50GHz, 2712 Mhz, 2 Core(s), 4 Logical Processor(s)
  • GPU: DirectX
  • Citra Version (found in title bar):
  • Game: pokemon Omega Ruby
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (48.3 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.
#3

what is that even mean?

#4

Disable ‘Enable Hardware Shader’, also download and install the latest drivers for your GPU.

#5

it doesn’t work… and when i disabled that the game just got so laggy than before and still freezes

#6

ummm, nevermind it worked! the black screen is gone now but my gameplay got so laggy with 20-30fps :cold_sweat: what should i do now?

#7

hiii, sooo its weirdd tho because just now when i tick and untick the enable hardware shader… the freezing scene or black screen is now gonE!
but it still laggy sometimes hmm

#8

This is due to a problem with intel iGPU’s which currently requires disabling hardware shaders which reduces performance.

#10

So i should disable the hardware shaders option on intel then?

#11

Only if it causes problems.

1 Like
#12

Okay then lemme try later thanks!

#13

So now i already disabled the enable hardware shader and reduced the hardware shader on intel but it got still laggy and freezes sometimes but after that the game still running with that freezing screen

#14

Hardware shaders are likely to cause problems on intel, and disabling will reduce performance, you have to compromise unfortunately.