Black screen - Pokemon X

Describe the issue
When I open the game, I get to pick the language and see the title screen before the screen goes black. Audio is still playing and pressing random buttons produces corresponding sounds, so it appears the game is still running.

System Information

  • Operating System: Windows 10
  • CPU: Intel(R) Core™ i5-6400 CPU @ 2.70GHz 2.70 GHz
  • GPU: Intel(R) HD Graphics 530
  • Citra Version (found in title bar): Citra Nightly 1802
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):
    Title screen:

After title screen:

Diagnostic Log
citra_log.txt (34.7 KB)

System Information for Support

Client Version                               Nightly 1802   HEAD-a93d7a8
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) HD Graphics 530
GPU Driver Version                           26.20.100.8142
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

I installed the most recent driver for my graphics card from Intel’s website. Unfortunately, the issue persists. Might there be some other issue?

Upload a new log please.

Here you go:
citra_log.txt (51.0 KB)

System Information for Support

Client Version                               Nightly 1802   HEAD-a93d7a8
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) HD Graphics 530
GPU Driver Version                           26.20.100.8142
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

Latest Intel drivers end with 101.XXXX so it’s not the latest.

Do you only have integrated graphics or do you also have a graphics card?
I know i5-6400 is a desktop CPU so you could pair with one.

You can get latest iGPU drivers for i5-6400 here: https://www.intel.com/content/www/us/en/products/sku/88185/intel-core-i56400-processor-6m-cache-up-to-3-30-ghz/downloads.html
Direct link: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe

Tbh, I don’t know if I only have integrated graphics or also a graphics card. Which leads me to believe that I probably only have integrated graphics.

I also noticed that my Driver Version had not changed between the two Bot messages, so I tried downloading the driver you linked to and install it manually, instead of the Support Assistant Intel offers, which I used the first time around.

The driver is downloaded now, but when I click yes to running the install program, nothing happens. Will keep you posted, if I get it to work. Unless you have any idea, why nothing happens?

You can go to Device Manager and expand the “Display Adaptors” category to see if you have more than one.

If you have more than one, you just need to connect your monitor to the correct HDMI/DVI/DP output at the back of your computer. Typically the outputs from a graphics card is horizontal while the motherboard is vertical.

e.g:

Just checked Device Manager; I only have the one.

The installation window for the new driver finally emerged:

However, I get the following error message:

Here is the error log:
IntelGFX.log (9.7 KB)

EDIT
I’ve found a possible solution to the error message, currently attempting to see if that will fix it.

Ah with locked issue you need to downgrade to 6373 manually and then update to the latest version.

Download https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed the latest version (the one I linked you before) you should do this so Windows won’t accidentally roll back to an old version:
https://web.archive.org/web/20190208013517/https:/download.microsoft.com/download/f/2/2/f22d5fdb-59cd-4275-8c95-1be17bf70b21/wushowhide.diagcab

You want to hide the Display driver, like this:
image

@tywald

I looked up a few guides on youtube and stuff, and I think I managed to do it somehow. I probably ended up doing the method you’ve described here, but I honestly couldn’t tell you (I’m no techie as you can probably tell :wink:)

In any case, the game seems to be running beautifully now. Thank you so much for all your help, I truly appreciate it :smile:

1 Like