Black Screen Upon Starting Game (Mac)

citra_log.txt (14.8 KB) Issue:

Attempts to play either Alpha Sapphire or Omega Ruby have both been met with blackscreens and 0 FPS. I’ve been exploring other topics featuring similar issues, and have attempted some fixes, including:

  • Disabling the disk shader cash
  • Disabling the hardware shader
  • Trying both the Nightly and Canary builds.
  • deleting the ROMs and reinstalling them.

Unfortunately I haven’t found a solution yet.

System Information

  • Operating System: Mac OS
  • CPU: 2.6 GHz 6-Core Intel Core i7
  • GPU: AMD Radeon Pro 5500M 8 GB
  • Citra Version (found in title bar): Canary 1956
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1956 HEAD-7a60d46
Operating System                              macOS 11.2
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD Radeon Pro 5500M OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Try disabling Hardware Shaders in Citra>Preferences>Graphics>Advanced Tab.

1 Like

No change with Hardware Shaders disabled.

MacOS seems to have issues with some of the recent changes made in Citra. Perhaps your issue is related to that. Please try out this older Citra version to test this:
Download citra-osx-20200707-bd7ee8c.tar.gz from Release nightly-1587: Common: remove a mod from AlignUp (#5441) · citra-emu/citra-nightly · GitHub
Extract it and then run the citra-qt executable found inside of the extracted folder.

I don’t know if it’s the same issue but when I run Citra on my M1 Macbook Pro (through Rosetta or natively compiled on my own, it’s the same issue) for some reason I get a grey screen when I start a game until I put it in full screen. I can then revert back to windowed and it works fine afterwards… so my workaround is just changing to fullscreen and then changing back to windowed…

M1 Macbooks aren’t supported, so that’s to be expected.
When you encounter the backscreen, do you hear any sounds on the background?

I’m aware it’s not supported :slight_smile: not complaining, just sharing my observations and the bug sound kind of similar (not the same though)

No luck with 1587, same result as with Nightly 1703 and Canary 1956. and regarding another reply from below, there are no sounds from Citra either. I must amend my earlier statement though, as I don’t think I was thorough enough in my description of the start up experience. Upon starting a game I get the brief “Now Loading” and game logo followed by a white screen, then after a second the black screen arrives.

You could also try turning off Accurate Multiplication. Though if that also doesn’t work, I’d recommend you redump your games entirely. For that, please refer to our Game Dumping Guides:

Dumping Game Cartridges
Dumping Installed Titles

Make sure your GM9 is updated to the latest version available and that you have enough free storage space available on your SD-Card to perform the dump.