Black Screen with freezing Citra but hearing the Game-Sound

Issue:
Hey everyone,
when I load a game, I always get a black Screen with freezing Citra at any game (no response from the software, so I have to quit Citra with the Task Manager of Windows), but you can hear the sound of the game after a while/few seconds.
I’ve tried everything recommended on the internet (amongst others to (un)check the boxes in the advanced graphic settings, delete the opengl folder, using older versions of citra and so on)…
I’m done with my knowledge…, hope you can help me
Thanks a lot and best regards

System Information

  • Operating System: Windows 10 64-bit
  • CPU: Intel Core i9-9900K
  • GPU: NVIDIA GeForce RTX 2080 Ti
  • Citra Version (found in title bar): Citra Nightly 1776
  • Game: The Legend of Zelda Ocarina of Time 3DS
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296
citra_log.txt (4.0 KB)

citra_log.txt (10.2 KB)

System Information for Support

Client Version                               Nightly 1776   HEAD-6764264
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            NVIDIA GeForce RTX 2080 Ti/PCIe/SSE2
GPU Driver Version                           471.96
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. Official Drivers | NVIDIA
  • Please enable the Vsync option if you are experiencing screen tearing.

Nobody knows? No one got a clue/hint?

Have you tried updating your GPU drivers?

Yes, but it didn’t solve the problem :frowning:

Please upload a new log file with the updated drivers.

citra_log.txt (19.3 KB)

What is curious is that a while ago I was able to play Ocarina of Time with citra-valentin for two days, then had the same error without me changing anything. It’s so random :frowning:

Ah. In that case lets try a portable build to rule out any other issues in appdata:

Go to Download Citra - Citra and select Manual download. Then under Nightly Build, click on your operating system’s icon to the right of the latest build available to download the build.
Extract it (.7z can be extracted using Winrar or 7zip) and put it wherever you wish. Inside the extracted nightly-mingw folder, create a folder called user. This Citra should now store all of its config, save files and such inside of this user folder.
Check to make sure that this user folder is in the same folder that contains citra-qt(.exe)
Now run the citra-qt executable found inside of the mingw folder and launch your game. If the issue persists, upload a log file using this portable build.

1 Like

Thanks for your help.
Luckily it worked for two game sessions like many times in the beginning. After two reboots I have got black screens now again and can’t play anything… I don’t understand this… It’s so frustrating.

Well, you know what to do.

It’s so strange, Citra is running again at the moment. I haven’t changed anything in the settings. The only question is when the error occurs again. I will send the log file as soon as the error occurs again. Annoying because you can never be sure when the black screen will appear again for a long time.
Tanks for your kind help and a Happy New Year.

It’s indeed very strange. Given the nature of the issue, it kinda sounds driver related but I’m really not sure. You’re already on the latest GPU driver available from what I can tell, but there’s always the chance that something small went wrong during the installation, that sometimes snowballs into manifesting the problem you’re having. Let’s just hope that this was a one time thing :pray:

Happy new year!

1 Like

That’s true. Now the black screen is back after a pc-reboot… :frowning:
citra_log.txt (15.6 KB)

Now citra is working again with this log.
Do you see any difference? I didn’t change anything.
citra_log.txt (17.6 KB)

It seems like it stopped working during the loading process and it couldn’t load the game anymore, but why?

You won’t believe what seems to be the error. I use multiple screens (four monitors). When I start Citra on the main monitor (1) the game appears as intended. If Citra is running on the second, third or fourth monitor, I have a permanent a black screen. wtf…

Ah, I have some idea of why you get a blackscreen then. Your Intel CPU has an integrated GPU. When you launch a program on a different monitor than your main one, it’s very possible that it’s passing through the integrated Intel GPU first, before being fed to your main GPU depending on what the program requires graphically. This poses a problem for Citra, since after launching a title in Citra (and thus before any load is given to the GPU), the driver that is being used (which is the Intel driver) gets locked. This is to prevent GPUs switching mid-emulation, and causing graphical issues/crashing due to shader cache mismatches. Your Citra would be running on your Intel iGPU drivers.

Now, it just so happens to be that a common cause of blackscreen with audio on Windows is out of date Intel GPU drivers when using an Intel iGPU. I didn’t see this as an issue before since the log file was reporting your NVIDIA GPU, rather than your Intel one. But that doesn’t always rule this issue out, so I probably should’ve thought to check for this. My bad.

In any case, updating your Intel GPU drivers should fix the issue. To update, download and install gfx_win_101.3790_101.2114.exe from Intel® Graphics – Windows* DCH Drivers
Mirror download: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe

Let me know if you encounter any issues during the installation.

1 Like

Yes, I’ve already updated my Intel GPU drivers.
Thank you for your kind, competent and comprehensive help. I’m so glad Citra works now.
I wish you only the best. Well done, good job @SleepingSnake :slight_smile:

1 Like