Blackscreen 0FPS no fix from this community worked yet

Issue:

When starting the Rom, there is only a black screen and nothing else. The Rom is fine (on my desktop pc, it runs flawlessly). However on my laptop, this happens in both versions, nightly and canary.

System Information

  • Operating System: Windows 10 Pro
  • CPU: Ryzen 7 5700U
  • GPU: Vega 8
  • Citra Version (found in title bar): Canary 1986
  • Game: Pokemon Omega Ruby ver 1.4
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (10.1 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1986 HEAD-f083b3a
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 5700U with Radeon Graphics          | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) Graphics
GPU Driver Version                            20.40.28 27.20.14028.6
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Please update your GPU drivers to the latest version available: https://www.amd.com/en/support/apu/amd-ryzen-processors/amd-ryzen-7-mobile-processors-radeon-graphics/amd-ryzen-7-5700u

I am still having the same problem, it is now on the most up-to-date version.
And i should mention, that it does the exact same thing under arch linux as well

Please set up a portable Citra build and test out if the game behaves the same there. However, make sure to not install any game updates. We want to rule out as much as possible after all:

Go to Download Citra - Citra and select Manual download. Then under Nightly Build, click on your operating system’s icon to the right of the latest build available to download the build.
Extract it (.7z can be extracted using Winrar or 7zip) (.tar.gz can be extracted natively on MacOS) and put it where ever you wish. Inside the extracted mingw folder, create a folder called user. This Citra should now store all of its config, save files and such inside of this user folder.
Check to make sure that this user folder is in the same folder that contains citra-qt(.exe)
Now run the citra-qt executable found inside of the mingw folder.

The Problem is still there, exactly like before. Here is my log-file, in case now theres something useful:
citra_log.txt (15.2 KB)

System Information for Support

Client Version                                Nightly 1721 HEAD-89410c1
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 7 5700U with Radeon Graphics          | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon(TM) Graphics
GPU Driver Version                            21.6.1 27.20.22001.14011
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

At this point, I’d recommend redumping your game. Please refer to our game dumping guides:

Dumping Game Cartridges
Dumping Installed Titles

Make sure your GM9 is up to date and that you have enough free storage space available on your SD-Card to perform the dump.

I dumped the title again. Tried it on my Laptop (the pc with the problem) and it did not work, however it still runs just fine on my normal desktop PC.
However even though i do not understand a thing, i looked through the log myself and noticed lots of “missing”, “not found”, “failed to open”, etc.

Please upload another log file.

It actually worked this time (had to redo everthing because i deleted the rom and citra out of frustration xD).
This time however, instead of dumping and decrypting the rom “the old fashioned way”, i used threesd and followed the documentation and boom, it works. Thanks for your advice :+1:

Edit:
I actually did not know, such an amazing tool existed. I only knew the classical way (dumping, decrypting, adding it to citra).