Bravely Default-Circle Pad issues

Issue:
I am using a controller and I have an issue in the battle menu. Whenever I try to use the analog stick to push left or right in the battle menu it does nothing. It’s supposed to switch to enemy/ally health but it doesn’t. The stick works perfectly fine in any other situation though. The only way to fix this is to manually set the directions of the circle pad (as opposed to “set analog stick”) using the analog stick on my controller. Only then will the battle menu register me pushing left or right on the circle pad. This wouldn’t be an issue if this didnt make character movement only go up/down and left/right. No diagonal, no range of motion. You are either pushing the circle pad all the way or you aren’t.

System Information

  • Operating System: windows 10
  • CPU: i7 7700HQ
  • GPU: Nvidia GTX 1050 Ti
  • Citra Version (found in title bar): nightly 1463
  • Game: Bravely Default
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.citra_log.txt (16.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1463 HEAD-3b1b8b7
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

What is your controller?

It’s the power A controller for nintendo switch. Though i dont think its the controller because it works perfectly.

I see, I will check tomorrow if I can replicate this on a PS3 controller if it can also happen on others.

So i just tested my xbox controller and it works. So I guess it is the controller? But I don’t understand why the switch controller would work perfectly fine in the overworld but completely not register in battles.