Bravely Default random crashes on battle start and save state

Issue:
Sometimes when the “battle starting” animation ends, instead of loading the battle itself, the game crashes, and I’m back to the game selection menu, so citra itself does not crash. Is very common that the first battle after loading the game crashes, and when it doesn’t, a significant drop of fps happens.

The other problem I have is when trying to save state, the game also crashes. Usually I’m back to the game selection menu, but sometimes the app crash.

The first error I can’t recall if always happened but it is becoming more common the more I play. I can confirm being able to save state with no problems when I first started the game. No updates to neither phone or app done since (Just a reinstall of the app to test).

System Information

  • Phone: Xiaomi Mi Mix 2s - 6GB RAM
  • Operating System: MIUI Global 12.0.3 Stable / Android 10 QKQ1.190828.002
  • SoC: Qualcomm Snapdragon 845
  • CPU 4x 2.8 GHz Kryo 385, 4x 1.8 GHz Kryo 385
  • Cores: 8
  • GPU: Qualcomm Adreno 630, 710 MHz
  • Citra Version (found in title bar): a6860a965
  • Game: Bravely Default - No textures packs used

Diagnostic Log
citra_log.txt (10.4 KB)
This log is the larger I’ve seen, usually the error is just the first two “failed to load file”.
I can also confirm the files failing to load does not exist inside citra-emu path.

I hope all this info helps.
Thanks for your time.

1 Like

This particular log file seems to have been generated after saving a Save State, correct?

Yes, that’s correct, trying to, the save state did not actually save.
I’m not sure if this one actually crashed the app or only the game, sorry.

Save States crashing sometimes is nothing new. They aren’t the most stable of things. I’m more curious about the first crash situation that you spoke off. If it’s possible. When you encounter such a crash again, close the Citra app and upload the log file here immediately after. Hopefullly it logs something before the crash that helps us figure out why this happened.

Just to be sure, do these crashes also occur when you don’t use Save States at all? Meaning by only using in-game save files.

I’ve tried a few times and didn’t have any problems now (and game was running smooth). Later today I will try again to provide the log.

The little I’ve seen after that situation was the missing files to the start of this same log file, everything up to (at least) the 10th row of that file.

Again, will try later to provide the genuine log.

Yes, due to the Save States crashing I’ve been just using the ingame save. Only tried once to SaveState at the end of the gaming session just to check if it actually worked. In a normal session the crashes happens more than once at a random times.

I really only used SaveStates to load the game faster and because of the “real-time timers village” (the game states to leave the console on sleep-mode for it).

To provide more info, just in case is relevant: I remember a few days ago that a SaveState actually worked, but trying to do a second one (different slot) immediately after, crashed the game.

Maybe I will try to play a bit without even trying the Save States, just in case it may be corrupting something (if that makes any sense to you).

I leave them here, is basically what I said.
citra_log (1).txt (1.9 KB)
citra_log (2).txt (3.6 KB)

I did not used Save States at any point, and the crashed occurred 4 times in the span of an hour. None of those were on the first battle after loading the game.

I took a look at the citra_log.txt.old.txt file in the same folder and seems to have a more variety of things. Would you like me to upload that one? The modified date is the same as citra_log.txt

It has things like this:

[ 488.462906] Service <Error> core/hle/service/service.cpp:ReportUnimplementedFunction:161: unknown / unimplemented function 'ControlArchive': port='fs:USER' cmd_buf={[0]=0x80d0144, [1]=0x23, [2]=0x0, [3]=0x0, [4]=0x1, [5]=0x1, [6]=0x1a, [7]=0x0, [8]=0x1c, [9]=0x1}
[ 492.775029] Render.OpenGL <Warning> video_core/renderer_opengl/gl_rasterizer_cache.cpp:DownloadGLTexture:849: Unsupported depth/stencil surface download
[ 492.775130] Debug <Critical> video_core/renderer_opengl/gl_rasterizer_cache.cpp:operator():609: Assertion Failed!

After a new session the problem crashed the app too, so now I can provide with a better log file:
citra_log.txt (20.2 KB)

I’m starting to believe that the ingame save actually makes things worse. I had a few times that the game crashed on the next battle right after saving.

Again, no Save States used.
Hope this helps.

Hello,
@SleepingSnake to provide a bit more info:
I tested moving the save file, all available inside:

\sdmc\Nintendo 3DS\00000000000000000000000000000000\00000000000000000000000000000000\title\00040000\000fc600\data

To the PC Version of Citra (Nightly 1696) and there are no problems here.
I still would like to know a fix for the android version if possible.
Thank you for your time.

I’m not aware of any workaround for now, sorry. You can try to see if downgrading to Beta 12 fixes the issue first though: Release Beta 12 · citra-emu/citra-android · GitHub
If this also doesn’t work, you can do what I wrote down below.

As it stands right now, I reported it back to the devs, but I haven’t heard anything constructive back yet.
You could open up a github issue with information about the crash and the troubleshooting steps you took so that the devs can keep track of the issue easier.

1 Like

That version seems to work without problems for now.
I moved back the save from the pc version (i continued there for some hours) and I have been going around for like 10 minutes without a crash.

Thanks for your help.

Great!

Let me know if it crashes after playing for a couple hours.

Sure, i will.
What I’m not going to do is use Save States this time, at all. Just in case somehow the save got corrupted because of it, so i hope everything holds up.

Save states don’t work well on Citra versions that they weren’t saved on. Though trying to load them on other Citra versions won’t break them fortunately. But yea, you should try to not use Save States for now.

Just to have a closure, I’ve been playing hour(s) long sessions this past days and I didn’t have any problem with this app version so the issue is resolved.

Thanks for your help.

2 Likes

Thx for the thread. Hope it’ll work for me as well.