Bravely Default Slowdown fix?

Issue:
Hi there, so i;m currently running the most current version of Citra and for some reason the game lags a lot when I am running it (I just got to Ancheim). But the thing is though it was working fine in the first few areas apart from the odd slowdown so i’m not sure what the deal is. I stream the game using Streamlabs too so not sure if that is a factor? My CPU usage is in the 70-80 range when streaming. Any ideas?

System Information

Diagnostic Log
citra_log.txt (4.0 KB)

System Information for Support

Client Version                                Nightly 1285 HEAD-c81a96b
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [x]
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

edit:
Maybe, you should test it without streaming. also disable (or enable) ‘Enable Hardware Shader’, it may improve performance.