Bravely Second locked @ 40fps?

I saw videos where this game ran 60fps. I noticed the audio running slow, and decided to open up Fraps. 40fps locked. Checked my CPU usage, and it’s under 20% CPU usage. Meaning it’s locked @ 40fps without a CPU bottleneck. Locked meaning hard locked @ 40fps. Not a single frame higher or lower. Not even a fraction of a frame higher or lower.

PC specs:

I5 2500k @ 4.2ghz
12gbs DDR3 1600mhz ram
R9 390
Windows 10 64 bit

This game should run 60fps with the above specs, right?

citra is still in alpha and currently has little performance optimization , most games will run slowly regardless of system specs, there is no 40 fps lock in citra this is just low fps due to having no optimization and right now citra can’t use cpu efficiently so the low cpu usage is normal.

regarding the 60fps video it is mostly for people who own high end hardware (mostly powerful cpus and usually overclocked) or they edit the videos and accelerate them to 60fps

the result also may vary between cpu architectures.

the only fps locks that comes with citra are Vsync and frame limit but they will usually cap your fps around 60.

Does system ram speed effect the performance of Citra? It might not actually be the CPUs themselves, if it’s getting faster speed from DDR4 memory.

no i remember someone having fast ram posting in the old forums, they still had slowdown issues.

Cheats are not working, I’m using the lastest bleeding edge build. It won’t even let me save cheats. I input the cheats, check the boxes, click “save” and the window closes. Open the window back up and none of my cheats are saved, wtf?

Speed up with cheat engine also doesn’t work. I can set the speed hack to 1.2 or 2.0, and it’s a 0% improvement. It basically skips frames. I was hoping I could use something like frame skipping to make the game run faster.

The answer to your question about cheats has already been answered, please use the search function before posting.

Here is a SC example of what I’m talking about:

40fps locked everywhere in most towns, CPU usage is around 12%. No fluctuation in FPS. Citra is hard locking my FPS @ 40fps, and no, this is not hardware related. I don’t have any other programs running that would place a FPS limit either.

There is potential here for an absolutely massive performance boost, if someone could figure out why it’s locking me @ 40fps in this game, and make it to where it at least (fully) uses 1 CPU core. Most things run slow because it’s bottlenecking something, not because it’s not using the resources available.

Double check to see if FRAPS isn’t limiting your framerate to 40. There’s no reason why Citra would limit your framerate to 40. I also do not have the issue you seem to be having, neither do other users I’ve talked to.

Running the most recent Bleeding Edge build:

My framerate is a steady 60fps (with a fluctuation of about 4 fps).

i5 2000k has 4 cores and 4 threads meaning 8 logical cores. citra is using about 12% of cpu which is roughly 1/8 and with 8 cores it means its maxing out a single core as expected. Its not “hard locking” at 40fps like you are suggesting but rather its just maxed out the single core that it runs on. At this point, all you can do is wait for further improvements to citra to speed the game up. Multicore support is a long way off as it is a lot of work and will significantly complicate the code base.

“Threads” is the number of logical cores. A CPU like you describe would have 4 cores and 8 threads, so that’s not necessarily the problem @crimsonedge11 is having.

@crimsonedge11 Can you post the contents of your citra-qt.ini file? Another useful thing would be to download Very Sleepy and run it on Citra’s emulation thread and posting a screenshot of the results. If you’re using a nightly you’re going to have to download debug info before that’ll be useful, we have those somewhere but I don’t remember the URL. Can someone chime in with where to get those? Or just build it yourself.

1 Like

He already fixed the problem, it was some app or system register problem. I’ve suggested him to make a fresh install of the OS and test it, everything running ok with the clean OS. He also removed some programs that may cause this performance issue and solved it on the original OS he was using.

Full post (from GBAtemp):

“I can’t pinpoint the exact cause, but I uninstalled a bunch of software, and cleaned the registry, and reinstalled the Visual C++ runtimes, and the problem appears to have went away on Windows 10. One of those programs I had installed did something to the registry that Citra doesn’t agree with. I suspect it may have been radeonpro, system explorer, MSI afterburner, or rivatuner causing it, but I can’t be 100% sure on that. I uninstalled all those and cleaned their registry entries. So if anyone else runs into a similar problem with Citra locking FPS lower than it should be, you should look at similar types of software on your PC that I listed.”

1 Like

@yuriks oh, i totally misread that. Thanks for the catch.

https://ci.appveyor.com/project/citrabot/citra-nightly/build/artifacts is the url to get the debug symbols. As an aside, Its not hard to upload that to github as part of the release. I didn’t do that originally because I didn’t want to make the downloads page any more cluttered than it needed to be. It looks like debug symbols are used a little more often than expected, so any thoughts on putting the debug symbols on the download page?

@lg_0 awesome to hear!

FYI, I thought I fixed the problem, but it appears to come back, eventually.

What I did was install a fresh Windows 7 64 bit on a backup drive. Citra ran 85fps in the same SC above where you see it running 40fps. I had to set the FPS limited and Vsynch.

So I started tinkering around with windows 10 settings, and got it to run full speed, once. Upon reboot, the program goes back to running 40fps locked. I can’t get it to run full speed on Windows 10 anymore.

Also, even the Windows 7 version started running 40fps locked in those spots after I downloaded updates. I did a system restore on Windows 7 after it downloaded the updates to roll it back, and the emulator runs full speed again. Unfortunately, I already tried a system restore for Windows 10, and that doesn’t help.

So I’m still confused as hell as to what could be causing this. If someone could answer me the question of why would it run full speed on a fresh Windows 7 install, then go back to capping me @ 40fps after downloading updates, maybe we could get to the bottom of this. I got bare minimum drivers required on Windows 7, so I think we can safely eliminate certain frame limiting programs as being the culprit.

@yuriks, here is the config file settings.

[Controls]
pad_a=65
pad_b=83
pad_x=90
pad_y=88
pad_l=81
pad_r=87
pad_zl=49
pad_zr=50
pad_start=77
pad_select=78
pad_home=66
pad_dup=84
pad_ddown=71
pad_dleft=70
pad_dright=72
pad_cup=73
pad_cdown=75
pad_cleft=74
pad_cright=76
pad_circle_up=16777235
pad_circle_down=16777237
pad_circle_left=16777234
pad_circle_right=16777236
pad_circle_modifier=68
pad_circle_modifier_scale=0.5

[Core]
use_cpu_jit=true

[Renderer]
use_hw_renderer=true
use_shader_jit=true
resolution_factor=0
use_vsync=true
toggle_framelimit=false
bg_red=1
bg_green=1
bg_blue=1

[Layout]
layout_option=0
swap_screen=false

[Audio]
output_engine=auto
enable_audio_stretching=true
output_device=auto

[Camera]
camera_outer_right_name=blank
camera_outer_right_config=
camera_inner_name=blank
camera_inner_config=
camera_outer_left_name=blank
camera_outer_left_config=

[Data%20Storage]
use_virtual_sd=true

[System]
is_new_3ds=false
region_value=-1

[Miscellaneous]
log_filter=*:Info

[Debugging]
use_gdbstub=false
gdbstub_port=24689

[UI]
UILayout\[email protected](\x1\xd9\xd0\xcb\0\x2\0\0\0\0\x2\x46\0\0\0\0\0\0\aU\0\0\x4\x16\0\0\x2N\0\0\0\x1f\0\0\aM\0\0\x4\xe\0\0\0\0\0\0\0\0\a\x80)
UILayout\[email protected](\0\0\0\xff\0\0\0\0\xfd\0\0\0\x3\0\0\0\0\0\0\0\0\0\0\0\0\xfc\x2\0\0\0\x1\xfb\0\0\0\x1c\0W\0\x61\0i\0t\0T\0r\0\x65\0\x65\0W\0i\0\x64\0g\0\x65\0t\0\0\0\0\0\xff\xff\xff\xff\0\0\0]\0\xff\xff\xff\0\0\0\x1\0\0\0\0\0\0\0\0\xfc\x2\0\0\0\a\xfb\0\0\0\x18\0\x41\0R\0M\0R\0\x65\0g\0i\0s\0t\0\x65\0r\0s\0\0\0\0\0\xff\xff\xff\xff\0\0\0o\0\xff\xff\xff\xfb\0\0\0\x12\0\x43\0\x61\0l\0l\0S\0t\0\x61\0\x63\0k\0\0\0\0\0\xff\xff\xff\xff\0\0\0o\0\xff\xff\xff\xfb\0\0\0 \0G\0r\0\x61\0p\0h\0i\0\x63\0s\0\x44\0\x65\0\x62\0u\0g\0g\0\x65\0r\0\0\0\0\0\xff\xff\xff\xff\0\0\0_\0\xff\xff\xff\xfb\0\0\0"\0P\0i\0\x63\0\x61\0 \0\x43\0o\0m\0m\0\x61\0n\0\x64\0 \0L\0i\0s\0t\0\0\0\0\0\xff\xff\xff\xff\0\0\0\x8c\0\xff\xff\xff\xfb\0\0\0*\0P\0i\0\x63\0\x61\0\x42\0r\0\x65\0\x61\0k\0P\0o\0i\0n\0t\0s\0W\0i\0\x64\0g\0\x65\0t\0\0\0\0\0\xff\xff\xff\xff\0\0\0\x8c\0\xff\xff\xff\xfb\0\0\0 \0P\0i\0\x63\0\x61\0V\0\x65\0r\0t\0\x65\0x\0S\0h\0\x61\0\x64\0\x65\0r\0\0\0\0\0\xff\xff\xff\xff\0\0\x1\x9a\0\xff\xff\xff\xfb\0\0\0\x12\0\x43\0i\0T\0r\0\x61\0\x63\0i\0n\0g\0\0\0\0\0\xff\xff\xff\xff\0\0\0?\0\xff\xff\xff\0\0\0\x3\0\0\0\0\0\0\0\0\xfc\x1\0\0\0\x2\xfb\0\0\0\x10\0P\0r\0o\0\x66\0i\0l\0\x65\0r\0\0\0\0\0\xff\xff\xff\xff\0\0\0Y\0\xff\xff\xff\xfb\0\0\0\x14\0\x44\0o\0\x63\0k\0W\0i\0\x64\0g\0\x65\0t\0\0\0\0\0\xff\xff\xff\xff\0\0\0\xca\0\xff\xff\xff\0\0\x5\0\0\0\x3\xdb\0\0\0\x4\0\0\0\x4\0\0\0\b\0\0\0\b\xfc\0\0\0\0)
UILayout\[email protected](\x1\xd9\xd0\xcb\0\x2\0\0\0\0\0\0\0\0\0\0\0\0\x1\x8f\0\0\x1\xdf\0\0\0\0\0\0\0\0\0\0\x1\x8f\0\0\x1\xdf\0\0\0\0\0\0\0\0\a\x80)
UILayout\[email protected](\0\0\0\xff\0\0\0\0\0\0\0\x1\0\0\0\x1\0\0\0\x3\x1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\x4\xec\0\0\0\x3\x1\x1\0\x1\0\0\0\0\0\0\0\0\0\0\0\0\x64\xff\xff\xff\xff\0\0\0\x81\0\0\0\0\0\0\0\x3\0\0\x2~\0\0\0\x1\0\0\0\0\0\0\0\x64\0\0\0\x1\0\0\0\0\0\0\x2\n\0\0\0\x1\0\0\0\0\0\0\x3\xe8\0)
UILayout\[email protected]()
UILayout\microProfileDialogVisible=false
Paths\romsPath=C:/Users/Clayton/Desktop/citra/3DSgames
Paths\symbolsPath=
Paths\gameListRootDir=.
Paths\gameListDeepScan=false
Paths\recentFiles=C:/Users/Clayton/Desktop/citra/3DSgames/3DS1479 - Bravely Second - End Layer (USA) Decrypted.3ds
singleWindowMode=true
displayTitleBars=true
confirmClose=true
firstStart=false
Shortcuts\Disassembler\Set%20Breakpoint\KeySeq=F9
Shortcuts\Disassembler\Set%20Breakpoint\Context=2
Shortcuts\Disassembler\Start\Stop\KeySeq=F5
Shortcuts\Disassembler\Start\Stop\Context=2
Shortcuts\Disassembler\Step\KeySeq=F10
Shortcuts\Disassembler\Step\Context=2
Shortcuts\Disassembler\Step%20into\KeySeq=F11
Shortcuts\Disassembler\Step%20into\Context=2
Shortcuts\Main%20Window\Load%20File\KeySeq=Ctrl+O
Shortcuts\Main%20Window\Load%20File\Context=1
Shortcuts\Main%20Window\Start%20Emulation\KeySeq=
Shortcuts\Main%20Window\Start%20Emulation\Context=1
Shortcuts\Main%20Window\Swap%20Screens\KeySeq=Ctrl+Tab
Shortcuts\Main%20Window\Swap%20Screens\Context=1
Shortcuts\Disassembler\Start\KeySeq=
Shortcuts\Disassembler\Start\Context=1

can you try without Vsync enabled?, just enable limit frame rate

I’m already past troubleshooting minor ini file tweaks, and have moving on.

what happens if you disable both?, the game will run super fast at some point but try to go into an area where a lot of things to draw (building,npcs,enemy…etc)

No ini file tweaks that have anything to do with limiting frame rates do anything to fix this. In any combination.

I’ve tried multiple versions of the emulator. Around 6 different versions. With some versions having the user file in the emulation folder, and not in %appdata%. Every version of every emulator I try runs the exact same. They all got the 40fps lock. In some spots the emulator runs 60, but only indoors.

I’ve even done a CMOS reset on my motherboard and returned everything back to stock settings. No impact at all.

The issue I’m having with Citra doesn’t happen in any other games/apps.

So here is a summary of the problems:

  • Runs full speed on Windows 7 64 bit with no OS updates installed
  • Install updates, back to running slow again.
  • Uninstalled some programs, and cleaned the registry, got it to run full speed on Windows 10 once.
  • Rebooted the PC, goes back to running slow again. Can’t get it running full speed on Windows 10 anymore.
  • Above issues only happen with Citra, nothing else. All my other games run like they should.

@Yuriks, I’m not sure if this is what you want from Very Sleepy, but here it is:

Here is my theory, and this is based on the emulator and this game running full speed on Windows 7 with no updates installed.

There is something in windows registry causing this, a setting that one of the updates changes. So if anyone knows anything that might cause this in windows registry, I can try tweaking some settings with regedit.

As far as why nobody else has reported this issue, maybe they don’t recognize a problem, or they might not bring it up? Or they might just be sitting and waiting on a newer version of the emulator to fix whatever is causing it? The fact that this happens to me on 2 different OSs on 2 different drives means there could be some underlying issue with the way the emulator is functioning, and not just on my PC.