Brilliant Diamond - Black screen on overworld

Hi,

I am trying to play Pokemon Brilliant Diamond but I am having an issue where the overworld is a black screen. The introduction (meeting Prof. Rowan, selecting player character, inputting name of player and rival) works fine. However, once I have control of my character in their bedroom in the overworld, the screen is black. I can see text bubbles if I talk to other characters and the screen becomes visible only when I open the pause menu. While paused, I can see the overworld in the background.

I have tried turning off async shader building and using both CPU and GPU video decoding - neither one has worked so far.

Yuzu says it is up to date when I download the most recent installer. My PC specs are:
OS: Windows 10 (10.0.19043)
CPU: Intel Core i7-8565U CPU @ 1.80 GHz
RAM: 8 GB
GPU: Intel UHD Graphics 620 driver version 27.20.100.8935 Shader version 9.1 OpenGL version 4.6 OpenCL version 3.0 Vulkan version 1.2.154

yuzu_log.txt (397.9 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Update GPU Driver.
Intel 30.0.101.1069 date 11/11/2021:

Intel laptop/prebuilt users with old driver versions will have to follow this video tutorial: https://www.youtube.com/watch?v=BZG50Nm5sOM&t=72s
Use “iigd_dch.inf”

1 Like

Thanks for the help - my graphics driver was not up to date. However, after installing the one linked, I got a black screen with audio just after the language select menu. Async shader building was disabled and the issue occurred with both CPU and GPU video decoding. Here is an updated log.
yuzu_log.txt (394.2 KB)

1 Like

Try it with Vulkan see how it works, you need more Ram for iGPU, at last 16GB of Ram for better experience.

1 Like

Thanks so much for your help. Vulkan is working great.

More details for anyone having a similar issue:
Prior to updating my graphics driver, when trying to use Vulkan, I got the message “An error occurred initializing the video core” and the game would not boot. The only way I could boot the game was with OpenGL, which gave me the black screen on overworld issue described above.

I tried updating my drivers (Intel graphics on HP computer) through a driver autodetection feature on both HP and Intel’s websites. Each one gave me a different graphics driver. I tried both and still had the black screen on overworld error and the inability to use Vulkan. The issue is that these sites were not giving me the truly most up-to-date driver.

The graphics driver linked by @ionelush2001 was more recently published and is working with Vulkan, played through the first couple towns and no issues so far.

1 Like

I am not a fun of HP Computers or Laptops, I had some issues whit them.
I have MSI Mainboard, MSI Nvidia GPU, Intel CPU computer components, works like a charm with Windows 10 and now 11, only one problem, MSI they posted faulty BIOS update for Windows 11 support,
I send it to warranty for one month, had to use a 10 year old PC in that time, felt like I was going nutz.