[BUG] [FIXED] Yuzu 647 | Pokemon Sword | Yuzu stops emulating video but audio keeps playing or completely crashes

Hello there, first of all thanks for all the effort that you have been making in this community.

I was trying to emulate my copy of Pokemon Sword but, when I go to take the bag from my room, yuzu, like, stops emulating the video but the audio keeps playing. From yuzu I’ve enabled advanced logging and I saw this thing in the console in the exact moment that i take the bag:

[ 471.301322] Debug <Critical> core\hle\kernel\k_server_session.cpp:operator ():131: Assertion Failed!
handler is invalid!

I’ve tried changing every setting in the emulation section, changing the type of rom dump, disabling mods, dlc and updates but nothing worked at all. Can someone please help me? Thank you.

Useful infos:

  • Followed the guide here for optimizing yuzu and the BSoD gaming video
  • CPU: Intel i5 6400
  • GPU: NVIDIA 1060 6GB (Driver version: 466.63)
  • RAM: 8GB + 30GB (swap SSD)
  • Yuzu version: Mainline 647
  • Yuzu log: yuzu_log.txt (198.6 KB)

Log specific game infos:

  • Game Version: 1.3.1
  • DLC: 1, 2
  • Mod used: Force Max Resolution, No Outlines, Pokemon Retextured and Wifi fix
  • Multicore enabled
  • CPU Accuracy: accurate
  • GPU API: OpenGL with disk shader cache, async GPU emulation and NVDEC emulation
  • GPU adv.: VSync enabled, assembly shaders enabled, async shader building enabled
    and fast GPU time enabled
1 Like

Question answered in the official discord server. It is a kernel bug that has already been reported.

1 Like

Fix available in the mainline build 648 (EA 1767)

1 Like