Bug new update, error

Issue:
My citra updated and started to present some Bugs … like audio delay … the sound doesn’t follow the action. How do I solve this?

System Information

  • Operating System: Win 10
  • CPU: I5
  • GPU: RX560 4 MEGAS
  • Citra Version (found in title bar): 1858
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (4.6 KB) .

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first before closing Citra then immediately upload a new log.

citra_log.txt (203.6 KB)

System Information for Support

Client Version                                Canary 1858 HEAD-a34b8e8
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 560 Series
GPU Driver Version                            20.4.2 26.20.15029.27016
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

@tywald

Try change the Output Engine in the Audio tab to sdl2. Let me know if that works so I can report it to:

Which should have fixed the issue but it seems it’s still there (at least for you).

Other than that, you should do this:

Update the drivers: https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-560

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.