Button Spam, Invalid Keybindings, OR no registered inputs with Switch Pro Controller

Issue:
I’ve been using the Switch Pro Controller for the Pokemon 3DS games for a while now, and it’s worked fine. Plug it in via USB, Bluetooth, just fine. I used Citra’s configure menu and pressed the appropriate buttons to calibrate the controller. Functioning properly, it looks like this.

https://i.gyazo.com/49862b3fcba5aa4c7e065b05551efcce.png <

I took a short break from playing Citra for about a month or so, and tried setting up my old system. Problem is, now the controller’s on the fritz for some reason. If I plug it in via USB, all of the buttons start to spam and I lose all control. I’d take a video of it but last time I tried opening the game it almost deleted all my save data and I’m not doing that again. Instead, I’ll show what happens when I check its properties using Windows’ USB game controller setup: it looks like this.

https://i.gyazo.com/cd081f68d065a6aab0337a34e2ea92af.mp4 <

I would like to note that I am not pressing a single button or moving the stick in any way, shape, or form. It is sitting flat on the desk.

Eventually with a lot of finagling – trying to run Citra through Steam’s Big Picture mode, disabling Switch Pro Controller support, enabling Switch Pro Controller support, closing and restarting the game a bunch, safely removing and re-plugging in the controller, I managed to get it to calm down.

However, now there is another problem. The buttons, for some reason, are now bound to my keyboard keys. But instead of harmless letters, they’re functional keys that either cause issues or do nothing. Since I am a new user that cannot add more than two links, I will explain. A is Return, B is Space, X is PgUp, and Y is PgDn. L is Ctrl, R is Alt. Start appears to cancel out of whatever menu it’s in. The C-stick controls the mouse and the Circle Pad/control stick adheres to the arrow keys. Most buttons don’t even register on Citra’s configuration menu. I am pressing every button exactly as Citra asks, exactly as I did previously, but it just… doesn’t work.

Needless to say, even if Citra did accept those button inputs as something connected to the keyboard, having Start act as the “cancel” button would cause a great many problems by itself.

Before you suggest to go wireless, I tried that. It was what worked yesterday, but now when I attempt to unplug the controller and work with Bluetooth, Citra does not register any inputs at all. I may as well not have a controller.

I have scoured the internet and cannot find a working answer to my problems. This is really quite infuriating as I just want to play Pokemon with my mom. She’s had foot surgery and we’re stuck in this house for two weeks. I’m at the end of my rope. Please help.

TL;DR: Wired Switch Pro Controller presses every button at once and cannot be played, OR the buttons it registers are function keys that half the time just cancel out of the config menu. Wireless Switch Pro Controller does not register at all.

And yes, I have tried Big Picture Mode, running Citra through Steam. It does not help at all.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i7 @ 2.20GHz
  • GPU: NVIDIA GeForce GTX 1060
  • Citra Version (found in title bar): Citra Canary 1465
  • Game: Pokemon Ultra Moon
  • Screenshot of Issue (include the full Citra window including titlebar): Included in explanation

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (391.5 KB)
Not sure what it will help since it’s not a crash or game bug but here

System Information for Support

Client Version                                Canary 1465 HEAD-e9faa33
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1060/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            388.73
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Sorry to tell you this, bot, but my problems ain’t graphical

Here’s a gif of some menus going on the fritz. Again, I am not touching the controller.

https://i.gyazo.com/cdde60620f8adf7e45be8be3f58d2620.mp4

EDIT: ZL appears to be equivalent to the right mouse button, or right-clicking.

EDIT 2: Alright, I solved it. Not sure if this will work for anyone else.
I unplugged the controller from the USB, and the USB from the computer.
I restarted the computer.
I went into Devices and Printers, removed the Pro Controller, and then added it again.
Then I started up Citra, opened the configuration menu, and re-set the buttons to where they should be.
Now it works.

I’ll note that re-setting the buttons appears to be important: even though the names of the buttons don’t change, if I don’t, the controls don’t work.

Now it works. I might have to do this every time, because I remember fixing it yesterday but not how. This might be it. If it works for you, great. If it doesn’t… I hope someone else replies to this.