Camera functions not work after Windows update

Issue:
Camera stopped working for me completely in after Windows 10 update, but only in Citra, other apps works fine. I know that’s unusual but I’m using my Android device as camera (which worked perfectly before) with DroidCam app. now I don’t have any image in games or even in preview options. I’ve tried other apps and solutions including disabling FrameServerMode in Windows Registry and had no luck with that. Any help with that problem will be useful.

System Information

  • Operating System: Windows 10 Professional
  • CPU: Intel Core i5-4570
  • GPU: NVidia GeForce GTX960
  • Citra Version (found in title bar): Citra Canary | HEAD-16302ea* Game: Pokemon Ultra Moon

Diagnostic Log
citra_log.txt (61.7 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

You can try older Canary versions and see if they work.

Well,I’ve tried some of them but none of them worked. I still have the same error message.

I have an idea of what caused the issue, but I’m not sure.
Please retry with Canary <=535 and report the results.
Thanks!

1 Like

No, still nothing. I still get the same error

‘[ 14.116442] Service.CAM citra_qt/camera/qt_multimedia_camera.cpp:GetHandler:134: Successfully got handler 0
Failed to get the supported modes of the video control
Invalid viewfinder settings
Failed to configure preview format’

That’s not the same error. (though similar), but anyway that is not helpful.
Can you see any cameras’ names in the Camera combobox?
You can try selecting any of them and have a test.

1 Like

I have three option in there and I get the same result on all of them, no preview or image in games.

These are the names of the devices on the list:
@@device:sw:{860BB310-5D01-11D0-BD3B-00A0C911CE86}\{628C6DCD-6A0A-4804-AAF3-91335A83239B}
@@device:sw:{860BB310-5D01-11D0-BD3B-00A0C911CE86}\{4F61B096-2A54-48C9-9AFB-784F1678DFAE}
@@device:pnp:\\?\root#image#0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global

Ok, so today after updating Citra I’ve got a new error:

[ 1.441884] Frontend citra_qt/main.cpp:OnUpdateFound:544: No updates found
[ 6.484523] Service.CAM citra_qt/camera/qt_multimedia_camera.cpp:GetHandler:136: Successfully got handler 0
No capture device found
No capture device found
No capture device found
No capture device found
[ 14.235372] Service.CAM citra_qt/camera/qt_multimedia_camera.cpp:GetHandler:136: Successfully got handler 1
Failed to get the video control
failed to find the video proc amp
No capture device found
Invalid viewfinder settings
Failed to configure preview format
[ 14.615670] Service.CAM citra_qt/camera/qt_multimedia_camera.cpp:ReleaseHandler:150: Successfully released handler 0

@Patrix96
Please check that Camera combo box again.
Likely it is because Citra can no longer find the device you specified.
After all the issue is not solved, I think.


I think it may be because QCamera does not work well with your emulated camera. If so we cannot actually do anything about that. I compiled a camera example from Qt for testing:
camera example
(Compiled with Qt5.10.0 msvc, with windeployqt)

If the example cannot run well, likely it is an issue of Qt or your camera.

1 Like

Ok, so I’ve tried all devices again on Citra, but none of them worked, but on example you’ve compiled all of them worked fine. And you may be right with correctly detecting devices because before update one of them was named DroidCam Source, and the other one MJPEG Camera

Ok, this topic is probably already dead but I’ve got some time to check more of the older versions of Citra Canary and the latest that worked for me was Citra Canary-478 (HEAD-db43205). I have the preview and in-game image, but being unable to rotate image or mirror it is a bit annoying, so if anyone has a solution for that I would be really grateful.

Probably your camera (emulated) does not support setting framerates.
I’ll probably look into it a bit when I get some time.