Can sound be completely disabled for speed testing?

#1

Issue:
I am playing Harvest Moon, Skytree Village and in the main area where you farm and mine I can only get 5 to 7 FPS. I want to completely turn off all sound to see if that will help improve the FPS. In other areas of the game it will run between 16 and 19 FPS which is kind of playable.

System Information

  • Operating System: Windows 10 build 17134 (64-bit)
  • CPU: AMD FX-9590 8-core (4.72 GHz)
  • GPU: Radio RX 580 - GL_VERSION: 4.6.13547
  • Citra Version (found in title bar): Nightly 1230
  • Game: Harvest Moon: Skytree Village
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (12.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

System Information for Support

Client Version                                Nightly 1230 HEAD-2138db3
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [ ]
System Region                                 [x]

Here’s some issues I found with your log that might help.

  • LLE Audio is designed for debugging purposes. Using this option will slow down your game. Try changing to HLE audio.
  • CPU JIT should be enabled for the best performance. Please enable this option.
#3

I made the changes noted and that provided a good boost in performance except in the farming and mining areas. Only about 1 to 2 FPS increase in the farming and mining ares.

#4

i don’t think you can disable sound completely as most game’s game logic is tied to it somehow. you can set the audio output to null, maybe that reduces cpu time marginally, setting sound mode to mono may do the same (i have no idea). also disabling ‘Enable Hardware Shader’ may improve performance.

#5

I’ll try playing with the ‘Enable Hardware Shader’ and see what that does. I’ve tried the null setting and that didn’t do much. I’ll also look into Mono and see what that does. - Thanks for the feedback -

#6

Upgraded to Nightly 1231, left the audio alone and turned off ‘Enable Hardware Shader’ and now see 10 to 12 FPS in the forming and mining area. Running around 25 to 26 FPS in the rest of the game areas and inside buildings up to 30 FPS. I can live with this for now.

Thanks for the input and suggestions.

#7

you can also try this canary build since you can’t get better framerate, this build had a feature that improves performance when hardware shaders are disabled. since this build is some months old it lacks some features, also backup your save files just for safety if you decide to try it.

#8

Thanks bio3c. I’ll play around with it tomorrow and report back.