Can´t exchange in any pokemon game [solved]

When i try to exchange with a friend, the inviter’s game says that there is a connection issue, and the invited citra drops instantly to 0 fps, waht causes it?

System Information

  • Operating System: Windows 10
  • CPU: intel core i7 6500u
  • GPU: nvidia geforce 940mx
  • Citra Version (found in title bar): Citra canary #591
  • Game: Pokemon ultra sun/ Pokemon omega ruby

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (276 Bytes)

Both of you should try regenerating your console IDs in Emulation - Configure - System.

i can´t do it, i tried with the solution provided by you, but it stills the same, there is the log status at exact moment of the crash in the invited citra

[ 246.077419] Service.FRD core/hle/service/frd/frd.cpp:UnscrambleLocalFriendCode:133: (STUBBED) called
[ 246.078202] Service core/hle/service/service.cpp:ReportUnimplementedFunction:162: unknown / unimplemented function ‘SetProbeResponseParam’: port=‘nwm::UDS’ cmd_buf={[0]=0x210080, [1]=0x321f00, [2]=0x40000}
[ 246.210361] Service.LDR core/hle/service/ldr_ro/ldr_ro.cpp:UnloadCRO:414: Unloading CRO “DllPssMessageWindow”
[ 247.190941] Service.NWM core/hle/service/nwm/nwm_uds.cpp:DestroyNetwork:892: called with status 3
[ 247.242231] Service.NDM core/hle/service/ndm/ndm_u.cpp:LeaveExclusiveState:28: (STUBBED)
[ 247.408881] Service.LDR core/hle/service/ldr_ro/ldr_ro.cpp:UnloadCRO:414: Unloading CRO “DllUSPokecen”
[ 247.626497] Service.LDR core/hle/service/ldr_ro/ldr_ro.cpp:UnloadCRO:414: Unloading CRO “DllField”
[ 247.668606] Service.LDR core/hle/service/ldr_ro/cro_helper.cpp:ApplyStaticAnonymousSymbolToCRS:554: CRO “DllCommWait” exports 0 static anonymous symbols
[ 247.668640] Service.LDR core/hle/service/ldr_ro/cro_helper.cpp:operator():863: CRO “DllCommWait” imports 0 indexed symbols from “|static|”
[ 247.668643] Service.LDR core/hle/service/ldr_ro/cro_helper.cpp:operator():881: CRO “DllCommWait” imports 54 anonymous symbols from “|static|”
[ 247.668714] Service.LDR core/hle/service/ldr_ro/cro_helper.cpp:ApplyModuleExport:978: CRO “DllCommWait” exports 0 indexed symbols to “|static|”
[ 247.670222] Service.LDR core/hle/service/ldr_ro/cro_helper.cpp:ApplyModuleExport:995: CRO “DllCommWait” exports 1 anonymous symbols to “|static|”
[ 247.670425] Service.LDR core/hle/service/ldr_ro/ldr_ro.cpp:LoadCRO:376: CRO “DllCommWait” loaded at 0x006F3000, fixed_end=0x006F6000
[ 247.743801] Service.NDM core/hle/service/ndm/ndm_u.cpp:EnterExclusiveState:19: (STUBBED) exclusive_state=0x00000002
[ 247.743938] Kernel.SVC core/hle/kernel/svc.cpp:CreateMemoryBlock:1109: called addr=0x0884C000
[ 249.791632] Service.NWM core/hle/service/nwm/nwm_uds.cpp:DestroyNetwork:892: called with status 9

Can you get a full log file with it crashing?

Also, possibly the same problem as here and here. There was also another one, where, if I remember correctly, OP’s problem was that they needed to redump their shared font?

there are both of the logs
the invited log
citra_log.txt (571 Bytes)
the inviter log (is almost empty for some unknow reason)
citra_log.txt (571 Bytes)

these are the full logs with the moment when we try to exchange

This build canary#591 has problems caused by a PR.
Use a later build, or use nightly.

Thank you very much Zhaowenlan1779, you solved my trouble