Cannot chose directory (doubleclicking) // Freeze

Issue:
I ran 1460-nighty for months without any issues. After seeing it’s at 1696 by now I decided to update it. I deleted 1460 and installed 1696. Since it’s another folder and the old one has been deleted for good already I had to setup it again. I can easily start games via data - load file but since that’s a bit unhandy in the long run I wanted to set the directory to the rom files so I have them in the starting screen and just click on them there. (By doubleclicking on the message “doubleclick to add new folders”) The window to select the directory pops up but I can’t choose anything. Clicking on ok or cancel doesn’t work either, almost as if the emu freezes on that step. I waited for a few minutes but still no reaction.

System Information

  • Operating System: Kubuntu 20.04
  • CPU: AMD Ryzen 3 2200G
  • GPU: Radeon Vega included in the CPU
  • Citra Version (found in title bar): 1696 Nightly
  • Game: none, the emulator itself
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Not possible, it only repeats “Sorry, there was an error uploading that file. Please try again.”
Updated it here now: https://file.io/BeOi3IXJTfue

Edit: I ran it via console command and once I doubleclick on the main screen the following message pops up several times. Not sure if that’s related.
“kf.solid.backends.udisks2: Failed enumerating UDisks2 objects: “org.freedesktop.DBus.Error.Disconnected”
“Not connected to D-Bus server””[citra_log.txt|attachment]

Edit 2:
Apparently uploading works today.
citra_log.txt (4 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The log file is incomplete. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder and open up the log folder. Now keep that open in the background.
    2.Encounter the problem; crash/slowdown/glitch and close citra if it doesn’t do so by itself. Do not restart citra as that will wipe the log of important information!
  2. Now upload the log file in this chat.
    Hopefully it catches the problem.

Forum only gives me the “Sorry, there was an error uploading that file. Please try again.” message again when I drag the file in here…

Open up Citra and go to File>Open Citra Folder. Then open up the config folder and delete the qt-config.ini file found here. Then restart the Citra program and try to set the directory again.

There is no config folder.
cheats, log, nand, sdmc, shaders, sysdata. Later one being empty (and no hidden files)

Edit: Just checked the system. no qt-config file.

Ah my bad. Linux builds have that in a different diirectory. Navigate to ~/.config/citra-emu/. The config file should be there.

Checked there already. There is no citra-emu folder.
There used to be one with 1460 but apparently 1696 never created one.
Also checked the flatpak folder which has a org.cita_emu.citra folder but nothing.

The issue was already there when I had both versions installed so I deleted all folders by hand because I thought the two versions may interfere with each other and installed it again

((Sorry for double posting))

I managed to find the qt-config.ini in .var/app/org.citra_emu.citra/config/citra-emu/. Deleting it did not work.
I changed the line Paths\gamedirs\2\path=SYSTEM manually to my rom folder and it lists the games now.

The issue still persists but I at least managed to bypass it.

Yea, I’m not a linux guy so I’m sorry that I can’t be of much help in this.
Just a question though, was the 1460 build from our old flatpack builds? Or did you compile that manually?
Because the way we hosted that changed recently (as our flatpack builds had been broken for a while) and I don’t know if that change affected those who updated using the new flathub method.

No worries. The older version did had the folder where you mentioned it.

Both versions were flatpack builds, yes.