Cannot get mods working for Linux version of Citra (Steam Deck)

Issue:
Enter a description of your issue here, in full detail.

I was installing Citra on my steam deck, but I cannot get mods to work on it. I know these files work as I have used them on windows with no issues. The game I am trying is Fire Emblem Fates:Special Edition.

System Information

  • Operating System: Steam OS 3.0 / Arch Linux
  • CPU: AMD Custom APU 0405
  • GPU: AMD Custom GPU 405
  • Citra Version (found in title bar): Citra Nightly 1759
  • Game: Fire Emblem Fates/ Fire Emblem Fates Special Edition
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log (6).txt (34.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1759   HEAD-3df43f950
Operating System                             KDE Flatpak runtime
CPU                                          AMD Custom APU 0405 | AVX2 | FMA
Graphics API                                 OpenGL 4.6
Graphics Renderer                            AMD VANGOGH (DRM 3.45.0, 5.13.0-valve10.1-1-neptune-02144-g7fffaf925dfb, LLVM 12.0.1)
GPU Driver Version                           Mesa 21.3.8
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Added the logs from the windows version for comparsion.

Windows logs below

citra_logwindows.txt (432.4 KB)

System Information for Support

Client Version                               Nightly 1759   HEAD-3df43f9
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            NVIDIA GeForce RTX 3080/PCIe/SSE2
GPU Driver Version                           512.15
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You have mods installed. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Are you sure you used the correct folders when installing the mod(s)?

I was able to get this working. For anyone else having this same issue it seems that linux is more strict with the names of the folder it terms of capitalisation.While in windows its fine to have romFS in linux is must all be lower case.