Can't access download files

I first downloaded citra like am onth ago, and I was playing Fire Emblem Fates special edition (first Birthright then conquest) I was on my conquest playthrough a few days ago when I downlaoded a latest version of citra and it suddenly started crashing my game and not in any special event, randomly, where I played my last playthrough without any problem.

I guess was soemthing to do with the new version, so I tried to download a even newer version that came out yesterday, but when I click the link of windows (on download page) the page keeps loading and never ends, and I was like “well, guess we are going back to a older version”, but now it happens on every git page if i try to download any file. I thought it was a problem with git, but I download a file I had in a school project in git and it worked perfectly well.

Is this only my problem? Is there anyway to fix it?

If this is non related to citra and I should be asking this on gits forums please tell me gently, as it’s only happening with citra projects.

Anyway, is there any other way to download citra?


the servers are down right now, wait for sometime for them to come back up and you can download

Oh, guess im a bit dumb. Thanks you

Its related to Amazon S3 going down. We host our files on github releases, who stores them on S3 (apparently)

For a little fun, heres what twitter has to say about this I have a friend that works for amazon and he says things a pretty crazy over there right now haha