Can't add a game

Whenever I try to add a game it freezes and will stay like that until I close it. I’ve let it run for HOURS and it was still frozen when I came back. I’ve tried to add many games, and ALL have the same result. I’ve uninstalled and reinstalled it, I’ve looked it up and tried to find a video on how to fix it and couldn’t, I’ve tried everything I could find and nothing’s helped. Please help me, if I don’t play these games I won’t know what people are talking about and if I don’t know that… goodbye popularity.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Turn off Antivirus and see if it works.

it won’t let me, it’s frozen. The only buttons I can click are minimize and close

how do I do that? I SUCK at doing stuff with a computer. The only thing I’m good at on a computer is PLAYING MINECRAFT.

@Incineroar12344 can i get your pc specs???

1 Like

umm sure, lemme go get the paper I wrote them down on

it’s a Windows 10 I’ve had for a month. The specs are:
The processor is a AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 2.10 GHz
I have 12 GB of ram but my computer says only 9.92 GB is left
And the system type is a 64-bit operating system and a x64 based processor

can you tell me graphics card ram…

um, ok lemme just google how to check that :sweat_smile:

7126MB
:smile: :smile: :smile: :smile: :smile: :smile:

ignore the emojis, it wouldn’t let me reply until the post was at least twenty characters long.

How to close Windows Security.
1 Open Start .
2 Search for Windows Security and click the top result to open the app.
3 Click on Virus & threat protection .
4 Under the “Virus & threat protection settings” section, click the Manage settings option.


Or if you have other Antivirus give me the name for example “Avast”.

ok, gimme a sec, and thx for the help btw

Your antivirus sometimes blocks yuzu… Thus why you need to stop your antivirus sometimes…

ohhh, and I did it!!

Let’s see if that fixed it
Edit: nope it still is at “not responding”
(I reached the max replies someone can have on their first day, :unamused:)
Edit: I’ll do both
Edit: didn’t work so I made a new topic called “Can’t add a game (Continued)”

1 Like

Restart your PC and try again.

Check for gpu driver updates and update it if any…