Can't host a room with a friend

Issue:
So I’m playing Pokemon Y with my friends and we were thinking of battling eachother. So we tried to create a room but the same error keeps popping up. Something about host connection or whatever. Each of us tried to create a room, didn’t work. Direct room with an IP adress, didn’t work. But when we joined a random room it worked. Why is that?

System Information

  • Operating System *: Windows 10
  • CPU: Ryzen 5 3500x
  • GPU: RTX 2060
  • Citra Version (found in title bar): Citra Canary 1985
  • Game: Pokemon Y
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

You usually get an error in this situation telling you that the host needs to properly set up port forwarding. If the host doesn’t set up port forwarding in their router settings, nobody can join their multiplayer room(s).
You’ll need to look up how to do so on your particular router model. This is usually also explained in the router’s manual.