Can't Host Room: 'Room Not Registered'


#1

ive been using citra for like?? maybe 3 months and i never thought about playing on the multiplayer servers until i started playing the pokemon games so i could trade and stuff.

i found out recently that i couldnt create rooms despite being verified with my token from this forum account… and then i found out that maybe i dont have enough trust levels to host?

could me not being able to host correlate with the level i have on citra? everything seems to be fine, i just can’t host but can join servers just fine!

(main reason i wanna host is to find someone to trade with, the servers on there are kinda dull lol)

UPDATE: i can host on other platforms just fine with different games outside of citra (steam is one of them) so ik its not my mac thats the problem


#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.


#3

Are you sure your username and token are correct? did you click on ‘Verify’? because citra should display your forum pic besides your name on your room (i’m not 100% sure because i’m using a default name pic and not a custom pic). if you have an antivirus or a firewall, add an exception for citra-qt.

you also need to port forward whatever port you are using to create your room (you only need to port forward an UDP port). check your modem/router model/name and search online on how to port forward on it.


#4

s

ye. i was messing around with nightly and canary ;; i dont have antivirus up either :0!! and my firewall now allows incoming connections through citra-qt for both nightly and canary – just tried to host and the same pop up appeared :frowning:

i think ive done porting, too since i have no issues hosting rooms on other games & platforms??


#5

every single app is specific to the port it uses, make sure to port forward citra’s specific port (which is whatever port you use when you create a room).

however i haven’t port forward citra on my modem and i’m able to host a room without any error message (of course no one can connect with port forwarding). try this, close citra and deletethe qt-config.ini file on ~/.config/citra-emu/ or ~/.local/share/citra-emu/, its inside one of these folders or inside a folder inside them, i don’t remember exactly.

which citra build are you on? try using the latest canary/nightly build.


#6

updated canary this morning and i mostly use nightly!

s

not sure which one youre referring to since i couldn’t find it dhasklhdjsa


#7

the qt-config.ini file has to be in one of these two folders (or in a folder inside them) i mentioned above


#8

i clicked on every folder in both and i cant seem to find qt-config.ini, i’m on a mac if that helps? it doesnt pop up on search, either ;; - ;;

(sorry this is a bit difficult)


#9

maybe its different on mac, but its your config file, its where your citra settings is stored, maybe in a .ini file with a different name, but if you look inside you may see the your inputs, settings, etc.


#10

bio3c! I found out how to fix it!

it was the preferred game option. it was empty, but once i added games to my game directory instead of doing ‘load file’ i can now host!

My picture and user shows up now.

I would advise everyone who still have problems hosting to try this:

  1. put your game files into folders like i did!
    alpha sapphire (folder) -> alpha sapphire (file for game)
    ultra sun (folder) -> ultra sun (file for game)
    etc.

  2. if you don’t see the (+ ADD NEW GAME DIRECTORY) then load a game, click emulation and ‘stop’, the +ADD NEW GAME DIRECTORY should show up!

  3. when you reach to that part, double click on + and click on your game folder, NOT file!

  4. your games should pop up with an icon next to it, like this!

s

  1. when you post publicaly, preferred games should have options for games now!!

s

  1. when you host, your profile picture (if you have one :0), citra forum name & nickname should appear under members, and not just your nickname with no profile picture.

I hope this works for someone else too!! o uo