Can't load save states ("array size too short)

Issue:
Both games I have emulated shows the error “array size too short” when I load a save state. I have tried updating, and enabling accurate multiplication. I’ve also seen that trying to load it up on an old Citra version could work, but I don’t know which version I had when these saves worked. If there’s any way to find out which version I had at the time please let me know. All the info I could find related to this issue is from 2020 or 2021.

System Information

  • Operating System: Windows 10
  • CPU: Intel(R) Core™ i5-1035G4 CPU @ 1.10GHz 1.50 GHz
  • GPU: Intel(R) Iris (R) Plus Graphics
  • Citra Version (found in title bar): Citra Nightly 1752
  • Game: Style Savvy 3, Story of Seasons
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (13.5 KB)

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

The log file should report the hash of the build that you used to create the save state. Though, your log file is incomplete so it didn’t manage to do this. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder (Citra>Open Citra Folder if on MacOS) and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch and close Citra if it doesn’t do so by itself. Do not restart Citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.