Can't load save states: std bad_alloc

Issue:
Enter a description of your issue here, in full detail.
I get std bad_alloc when trying to load a game, i tried saving using the in-game option but it didn’t work. I also tried multiple versions of Citra.

System Information

  • Operating System: Windows 10
  • CPU: I7-9750H
  • GPU: Nvidia GeForce GTX 1650
  • Citra Version (found in title bar):
  • Game: 1497
  • Screenshot of Issue (include the full Citra window including titlebar):
    image-2021-11-09-175748 — ImgBB

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

This is an error that occurs when you’re attempting to load a save state on a different Citra version than the one it was created on. Save states are picky like that, hence why we don’t recommend that people only use save states to record their progress. Go to File>Open Citra Folder and open up the states folder. Upload your latest save state here, I should be able to figure out what Citra version(s) it was created on.

I did that, now what?

I don’t see any save state uploaded here. I need to take a look at it so you need to upload it here on the forums.

https://easyupload.io/m/g3h1fz
https://easyupload.io/m/o4s311
https://easyupload.io/m/mj8kc5

You’ve uploaded your save file, not your save state. Please read my original comment. This error occurs when loading a Save State that was created on a different Citra version than the one it is being loaded on. I need to figure out what Citra version that Save State was created on, for that I need the save state you’re trying to load. Please upload it.

Idk which one that is, help me.

please help me dude, idk which it is

Save states are stored in the states folder which you can access with File -> Open Citra Folder

https://usaupload.com/5soD/0004000000055D00.01.cst
https://usaupload.com/5soF/0004000000055D00.02.cst
https://usaupload.com/5soE/000400000011C400.01.cst
https://usaupload.com/5soC/000400000011C400.02.cst
https://usaupload.com/5soG/00040000001B5100.01.cst
These?

Yup, now you just need to wait for @SleepingSnake to check.

Since I’m in Europe, I appear to be unable to access those links. They appear to be restricted by region.

Could you upload these files to a different host? Something like Mega, Mediafire, Google drive and such are international hosts.

Could you also specify which game(s) you’re having these issues with? Since the previous links suggested that you’re using save states for multiple games.

Pokemon X, Ultra Moon, Omega Ruby, and idk.

Any help please? I need this

Pokémon X:
save state 1: Nightly 1630 or Canary 1866
save state 2: Nightly 1580 or Canary 1791

Pokémon Omega Ruby:
save state 1: Nightly 1649 or Canary 1886
save state 2: Nightly 1669 or Canary 1916

Pokémon Ultra Moon:
save state 1: Nightly 1623 or Canary 1852

Try these versions.