Cant open Pokemon Sun Ultra

Issue:
Enter a description of your issue here, in full detail.
I can’t open Pokemon Sun Ultra

System Information

  • Operating System: Mac OS Big Sur
  • CPU: 2.6 GHz 6-Core Intel Core i7
  • GPU: AMD Radeon Pro 5300M 4 GB
  • Citra Version (found in title bar): Nightly 1714
  • Game: Pokemon Sun Ultra
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (4 KB)

Your log is cut off. Did you accidentally upload the log while Citra was still open? You need to close Citra before you upload so it can save the log correctly.

Hi, yes that’s possible. Is this one ok?
citra_log.txt (5.4 KB)

System Information for Support

Client Version                                Nightly 1714 HEAD-5241032
Operating System                              macOS 11.4
CPU                                           Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz | AVX2 | FMA
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Please enable the Vsync option if you are experiencing screen tearing.
  • You have GDB debugging enabled. This will cause Citra not to launch games. This is only intended for debugging purposes and should be disabled in settings.

Turn off GDB Stub in the Debug tab:

image

Not sure why you turned it on as it is off by default.

Thank you. This has made it work but the game lags a lot when there is a lot of movement/effects on the screen

Make sure you turn on Hardware Renderer in the Advanced graphics settings. Your previous log shows that you have it off.

This has been turned on as well. It’s still a little slow, though.

Upload a new log, maybe there are more settings to tweak.

If there isn’t any then I’m afraid it could be just AMD’s GPU (Radeon) + being on a Mac that limits performance.

Sorry for the inconvenience.

check if the emulation in Audio tab is HLE(fast) ; this will increase your speed in case its turned off

Their log file said that they were using HLE audio to begin with. If they changed it, or something else, we wouldn’t know → Hence why tywald asked for a new log file.